summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSR_team2024-06-10 00:32:12 +0300
committerSR_team2024-06-10 00:32:12 +0300
commit0bdb887adcef3635854c324a52ecbfaadda0f42f (patch)
tree11f5dea7b40a025bb38d1c2eed5d3046cb891bc1
parentb56217b619d1e7a558edac53c12265b6efec1758 (diff)
downloadaur-0bdb887adcef3635854c324a52ecbfaadda0f42f.tar.gz
Provide cuda target for correct resolve dependencies
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a75cf644308..39154cdfd0d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = cuda-12.2
depends = nvidia-535xx-utils
optdepends = gdb: for cuda-gdb
optdepends = glu: required for some profiling tools in CUPTI
+ provides = cuda
provides = cuda-toolkit
provides = cuda-sdk
conflicts = cuda
diff --git a/PKGBUILD b/PKGBUILD
index 3a684c9dfe5e..0ecfb9ba068a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ arch=('x86_64')
url="https://developer.nvidia.com/cuda-zone"
license=('custom:NVIDIA')
replaces=('cuda-toolkit' 'cuda-sdk' 'cuda-static')
-provides=('cuda-toolkit' 'cuda-sdk')
+provides=('cuda' 'cuda-toolkit' 'cuda-sdk')
conflicts=('cuda')
depends=('gcc12' "opencl-nvidia-535xx" "nvidia-535xx-utils")
optdepends=('gdb: for cuda-gdb'