summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2016-05-15 00:47:49 +0800
committerJingbei Li2016-05-15 00:51:12 +0800
commitfbda6ca95e0a38ccf8087bd84451e6b9e7c31b63 (patch)
tree8f57c77c2dea525e8a55e2e71a607c6d2450cfe5
parent5201ec585bf8cd148ed7ca8ab6744568809c814f (diff)
downloadaur-fbda6ca95e0a38ccf8087bd84451e6b9e7c31b63.tar.gz
add patch for gcc6.1.1
contributed by TJM <tommy.mairo@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--gcc6.1.1.patch55
3 files changed, 67 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443e39dbfa3a..993ac5da3c37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Feb 26 07:48:40 UTC 2016
+# Sat May 14 16:49:51 UTC 2016
pkgbase = cudaminer-git
pkgdesc = CUDA accelerated mining application for scrypt coins(Litecoin etc.).
pkgver = 209.746a773
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cbuchner1/CudaMiner
arch = i686
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = cudaminer-git
depends = automake
depends = jansson
source = git+https://github.com/cbuchner1/CudaMiner
+ source = gcc6.1.1.patch
sha256sums = SKIP
+ sha256sums = 1e9727d44b3b1cc9e4e2a1fc013122bb401ab9c59bd5d368b5dd0af291f7af7c
pkgname = cudaminer-git
diff --git a/PKGBUILD b/PKGBUILD
index 23c90368b2cc..7d9ae758e636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: i@jingbei.li
+# Maintainer: Jingbei Li <i@jingbei.li>
+# Contributor: TJM <tommy.mairo@gmail.com>
pkgname=cudaminer-git
_gitname=CudaMiner
pkgver=209.746a773
-pkgrel=1
+pkgrel=2
pkgdesc="CUDA accelerated mining application for scrypt coins(Litecoin etc.)."
url="https://github.com/cbuchner1/CudaMiner"
arch=('i686' 'x86_64')
license=('GPL')
depends=('cuda' 'automake' 'jansson')
makedepends=('git')
-source=("git+https://github.com/cbuchner1/CudaMiner")
-sha256sums=('SKIP')
+source=("git+https://github.com/cbuchner1/CudaMiner" 'gcc6.1.1.patch')
+sha256sums=('SKIP' '1e9727d44b3b1cc9e4e2a1fc013122bb401ab9c59bd5d368b5dd0af291f7af7c')
pkgver() {
cd $_gitname
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
-
+prepare(){
+ patch -p1 $_gitname/Makefile.am < gcc6.1.1.patch
+}
build(){
cd $_gitname
- sed "s/\-arch=compute_10 //g" -i Makefile.am
./autogen.sh
CFLAGS=-O2 ./configure --with-cuda=/opt/cuda --prefix=/usr
make
diff --git a/gcc6.1.1.patch b/gcc6.1.1.patch
new file mode 100644
index 000000000000..d28366b541e9
--- /dev/null
+++ b/gcc6.1.1.patch
@@ -0,0 +1,55 @@
+--- CudaMiner/Makefile.am 2016-05-12 18:30:34.000000000 +0800
++++ Makefile.am 2016-05-12 19:34:50.497216667 +0800
+@@ -13,6 +13,8 @@
+
+ bin_PROGRAMS = cudaminer
+
++AM_CFLAGS = -O2
++NVCCFLAGS = -Xcompiler -std=c++98
+ cudaminer_SOURCES = elist.h miner.h compat.h \
+ compat/inttypes.h compat/stdbool.h compat/unistd.h \
+ compat/sys/time.h compat/getopt/getopt.h \
+@@ -40,33 +42,33 @@
+ cudaminer_CPPFLAGS = -msse2 @LIBCURL_CPPFLAGS@ @OPENMP_CFLAGS@ $(PTHREAD_FLAGS) -fno-strict-aliasing $(JANSSON_INCLUDES) -DSCRYPT_KECCAK512 -DSCRYPT_CHACHA -DSCRYPT_CHOOSE_COMPILETIME
+
+ .cu.o:
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=compute_10 --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
+
+ sha256.o: sha256.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=compute_10 --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
+
+ keccak.o: keccak.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=compute_10 --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
+
+ blake.o: blake.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=compute_10 --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" --maxrregcount=64 --ptxas-options=-v $(JANSSON_INCLUDES) -o $@ -c $<
+
+ # NOTE: now compiling for compute 1.0 again, as it's using less power and runs way faster on Linux
+ fermi_kernel.o: fermi_kernel.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=compute_10 --maxrregcount=64 $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" --maxrregcount=64 $(JANSSON_INCLUDES) -o $@ -c $<
+
+ kepler_kernel.o: kepler_kernel.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=sm_30 --maxrregcount=32 $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" -arch=sm_30 --maxrregcount=32 $(JANSSON_INCLUDES) -o $@ -c $<
+
+ titan_kernel.o: titan_kernel.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=sm_35 --maxrregcount=32 $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" -arch=sm_35 --maxrregcount=32 $(JANSSON_INCLUDES) -o $@ -c $<
+
+ # NOTE: now compiling for compute 1.0 again, as it's using less power and runs way faster on Linux
+ test_kernel.o: test_kernel.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=compute_10 --maxrregcount=32 $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" --maxrregcount=32 $(JANSSON_INCLUDES) -o $@ -c $<
+
+ nv_kernel.o: nv_kernel.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=sm_30 --maxrregcount=63 $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" -arch=sm_30 --maxrregcount=63 $(JANSSON_INCLUDES) -o $@ -c $<
+
+ nv_kernel2.o: nv_kernel2.cu
+- $(NVCC) @CFLAGS@ -Xptxas "-abi=no -v" -arch=sm_35 --maxrregcount=80 $(JANSSON_INCLUDES) -o $@ -c $<
++ $(NVCC) @CFLAGS@ $(NVCCFLAGS) -Xptxas "-abi=no -v" -arch=sm_35 --maxrregcount=80 $(JANSSON_INCLUDES) -o $@ -c $<