summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Stadler2017-11-17 15:22:55 +0100
committerLucas Stadler2017-11-17 15:28:24 +0100
commit255718f2b86844449372411e15f3cc08122c796d (patch)
tree97f630a244bea95ed0e89a1e8c45ab22b1a641d6
parentdcdf9bc25435c6904bff1e3e20c7c97a1786878a (diff)
downloadaur-255718f2b86844449372411e15f3cc08122c796d.tar.gz
Explain some weird stuff
-rw-r--r--PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0127957517df..7427c92d6dca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,15 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+ #
+ # CUDD is rather strange, so we need to make it work by copying some
+ # required files that aren't installed by `make install`.
+ #
+ # We rename `config.h` to `cudd-config.h`, but we can't do the same
+ # for `util.h` because some existing packages (e.g. http://hackage.haskell.org/package/cudd)
+ # depends on `util.h` unfortunately.
+ #
+
#cp util/cudd-util.h $pkgdir/usr/include
cp util/util.h $pkgdir/usr/include
#sed -i 's/config.h/cudd-config.h/g' $pkgdir/usr/include/cudd-util.h
@@ -40,5 +49,7 @@ package() {
cp mtr/mtr.h $pkgdir/usr/include
+ # This seems to be a 4-clause BSD license
+ # (https://en.wikipedia.org/wiki/BSD_licenses#4-clause_license_.28original_.22BSD_License.22.29)
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}