summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Stadler2017-11-17 15:18:51 +0100
committerLucas Stadler2017-11-17 15:28:17 +0100
commitdcdf9bc25435c6904bff1e3e20c7c97a1786878a (patch)
tree0d566fc4af8f326add8e8215029fd2146b836567
downloadaur-dcdf9bc25435c6904bff1e3e20c7c97a1786878a.tar.gz
Initial commit: Make it compile and build and install
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef1066d4844a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cudd
+ pkgdesc = A package for the manipulation of Binary Decision Diagrams (BDDs) and similar structures
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://vlsi.colorado.edu/~fabio/CUDD
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = gcc-libs
+ source = ftp://vlsi.colorado.edu/pub/cudd-3.0.0.tar.gz
+ md5sums = 4fdafe4924b81648b908881c81fe6c30
+
+pkgname = cudd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0127957517df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Lu Stadler <lu@papill0n.org>
+pkgname="cudd"
+pkgver="3.0.0"
+pkgrel=1
+pkgdesc="A package for the manipulation of Binary Decision Diagrams (BDDs) and similar structures"
+arch=('i686' 'x86_64')
+url="http://vlsi.colorado.edu/~fabio/CUDD"
+license=('BSD')
+depends=(gcc-libs)
+makedepends=()
+source=("ftp://vlsi.colorado.edu/pub/$pkgname-$pkgver.tar.gz")
+md5sums=('4fdafe4924b81648b908881c81fe6c30')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --enable-shared --enable-dddmp --enable-obj
+ #grep -lR util.h | xargs sed -i 's/util.h/cudd-util.h/g'
+ #mv util/util.h util/cudd-util.h
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ #cp util/cudd-util.h $pkgdir/usr/include
+ cp util/util.h $pkgdir/usr/include
+ #sed -i 's/config.h/cudd-config.h/g' $pkgdir/usr/include/cudd-util.h
+ sed -i 's/config.h/cudd-config.h/g' $pkgdir/usr/include/*.h
+ cp config.h $pkgdir/usr/include/cudd-config.h
+
+ cp mtr/mtr.h $pkgdir/usr/include
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}