summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragus-balles2023-11-08 18:09:26 -0300
committeragus-balles2023-11-08 18:09:26 -0300
commit6b8dd64fe6a76644e8806d4757a8c10c6ff92886 (patch)
tree3b88737141d5fa9d65dd09e8e6ad4f500d905f5a
downloadaur-6b8dd64fe6a76644e8806d4757a8c10c6ff92886.tar.gz
New package name
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c68a8b10bd2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cue-music-command-git
+ pkgdesc = A command-line music player
+ pkgver = v1.4.r9.g3faed2a
+ pkgrel = 1
+ url = https://github.com/ravachol/cue
+ arch = x86_64
+ license = GPL2
+ depends = ffmpeg
+ depends = fftw
+ depends = git
+ depends = chafa
+ depends = freeimage
+ conflicts = cue
+ source = git+https://github.com/ravachol/cue
+ sha256sums = SKIP
+
+pkgname = cue-music-command-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f6776b72a672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: <agustinballesteros04@gmail.com>
+pkgname=cue-music-command-git
+pkgver=v1.4.r9.g3faed2a
+pkgrel=1
+pkgdesc="A command-line music player"
+arch=('x86_64')
+url="https://github.com/ravachol/cue"
+license=('GPL2')
+depends=('ffmpeg' 'fftw' 'git' 'chafa' 'freeimage')
+conflicts=('cue')
+sha256sums=('SKIP')
+
+source=("git+${url}")
+
+pkgver() {
+ cd "$srcdir/cue"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/cue"
+ make
+}
+
+package() {
+ cd "$srcdir/cue"
+ install -Dm755 cue "$pkgdir/usr/bin/cue"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "$srcdir/cue/docs/cue-manpage.mdoc" "$pkgdir/usr/share/man/man1/cue.1"
+}
+