summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2015-06-09 13:44:04 +0300
committerEugene Lamskoy2015-06-09 13:44:04 +0300
commit8eb783d79b5f83a8c17d56fe362e58f17ad00748 (patch)
tree6b9c166f294701f84f3057471b771e8cd7edd064
downloadaur-8eb783d79b5f83a8c17d56fe362e58f17ad00748.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD30
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aae7d0800097
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = cue2tracks
+ pkgdesc = Bash script for slipt audio CD image files with cue sheet
+ pkgver = 0.2.16
+ pkgrel = 1
+ url = https://code.google.com/p/cue2tracks/
+ arch = any
+ license = GPL2
+ depends = bash
+ depends = cuetools
+ depends = shntool
+ depends = file
+ depends = glibc
+ depends = flac
+ optdepends = vorbis-tools: For OGG support
+ optdepends = flake: Alternative FLAC encoder
+ optdepends = mac: For APE support
+ optdepends = wavpack: For WavPack support
+ optdepends = shorten: For shorten support
+ optdepends = ttaenc: For True Audio Codec support
+ optdepends = lame: For MP3 support
+ optdepends = id3v2: For MP3 tagging support
+ optdepends = faac: For AAC in M4A support
+ optdepends = faad: For AAC in M4A support
+ source = https://cue2tracks.googlecode.com/files/cue2tracks-0.2.16.tar.gz
+ md5sums = f449aa804e8c3f9dd90a03f89f408fcc
+
+pkgname = cue2tracks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..355d02ac3594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=cue2tracks
+pkgver=0.2.16
+pkgrel=1
+pkgdesc="Bash script for slipt audio CD image files with cue sheet"
+url="https://code.google.com/p/cue2tracks/"
+license=('GPL2')
+arch=('any')
+depends=('bash' 'cuetools' 'shntool' 'file' 'glibc' 'flac')
+optdepends=('vorbis-tools: For OGG support'
+'flake: Alternative FLAC encoder'
+'mac: For APE support'
+'wavpack: For WavPack support'
+'shorten: For shorten support'
+'ttaenc: For True Audio Codec support'
+'lame: For MP3 support'
+'id3v2: For MP3 tagging support'
+'faac: For AAC in M4A support'
+'faad: For AAC in M4A support')
+source=("https://cue2tracks.googlecode.com/files/${pkgname}-${pkgver}.tar.gz")
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ install -d -m 755 $pkgdir/usr/bin
+
+ make install PREFIX="$pkgdir/usr"
+}
+
+
+md5sums=('f449aa804e8c3f9dd90a03f89f408fcc')