summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoic Coyle2021-04-16 00:13:17 +0200
committerLoic Coyle2021-04-16 00:13:17 +0200
commit3b539c7cd8b168029df655941b49818659fe0c08 (patch)
tree95429efb0f68ad97d39aa8cba6d0805c519a29c2
downloadaur-3b539c7cd8b168029df655941b49818659fe0c08.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8c72c3cad23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cuff-git
+ pkgdesc = Query the Jackett search API from the command line.
+ pkgver = r16.b3db6b0
+ pkgrel = 1
+ url = https://github.com/loiccoyle/cuff
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = curl
+ depends = jq
+ optdepends = jackett: Use many torrent trackers with software that supports torznab/potato feeds.
+ provides = cuff
+ source = cuff::git+https://github.com/loiccoyle/cuff.git
+ md5sums = SKIP
+
+pkgname = cuff-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abf69a0360ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Loic Coyle <loic.coyle@hotmail.fr>
+
+_pkgname=cuff
+pkgname="${_pkgname}-git"
+pkgver=r16.b3db6b0
+pkgrel=1
+pkgdesc='Query the Jackett search API from the command line.'
+arch=('any')
+url='https://github.com/loiccoyle/cuff'
+license=('MIT')
+depends=('curl' 'jq')
+optdepends=('jackett: Use many torrent trackers with software that supports torznab/potato feeds.')
+provides=('cuff')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/loiccoyle/cuff.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ install -D -m 755 cuff "${pkgdir}/usr/bin/cuff"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m 644 completions/zsh "${pkgdir}/usr/share/zsh/site-functions/_cuff"
+}