summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-12 16:40:32 +0000
committerGrey Christoforo2018-11-12 16:40:32 +0000
commit4a2013050e584c45392ea25deec8d1980955bdc1 (patch)
tree10808c3fbbe0e608bfb30ff5c664d86d0f774942
parent314e5f62ab94f1a744dc24e45660bb0e573f9f23 (diff)
downloadaur-4a2013050e584c45392ea25deec8d1980955bdc1.tar.gz
work on fixing build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d975f5ed588f..5b72ef9df685 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Jul 1 16:07:46 UTC 2016
pkgbase = cufflinks
pkgdesc = Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples..
pkgver = 2.2.1
- pkgrel = 3
+ pkgrel = 4
url = http://cole-trapnell-lab.github.io/projects/cufflinks/
arch = x86_64
license = Artistic
diff --git a/PKGBUILD b/PKGBUILD
index 66b9069129e5..2c1db98398a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cufflinks
pkgver=2.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples.."
arch=("x86_64")
url="http://cole-trapnell-lab.github.io/projects/cufflinks/"
@@ -11,16 +11,24 @@ depends=('boost' 'eigen3' 'python2' 'samtools' 'perl')
source=(https://github.com/cole-trapnell-lab/${pkgname}/archive/v${pkgver}.tar.gz)
md5sums=('80328ff4169f2778c0728a4795da85e2')
-build() {
+
+prepare() {
cd $srcdir/$pkgname-$pkgver
+
+ ./autogen.sh
# cufflinks uses python2 but archlinux uses python3 as default python
perl -i -pne '$_ =~ s/python/python2/ if $_ =~ /^#!\/usr/' src/cuffmerge
export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
export LDFLAGS="-L/usr/lib -lboost_system"
./configure --prefix=/usr
- make
+}
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
+ export LDFLAGS="-L/usr/lib -lboost_system"
+ make
}
package() {