summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-06-20 19:53:27 +0200
committerGrey Christoforo2015-06-20 19:53:27 +0200
commit6f37fa624d96622a558310aa808489813d4867bf (patch)
treecd93aff2018ce493968ee141544432432e9283e5
downloadaur-6f37fa624d96622a558310aa808489813d4867bf.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
3 files changed, 62 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a4cf8ab5ecf1
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = cufflinks
+ pkgdesc = Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples..
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://cufflinks.cbcb.umd.edu
+ arch = x86_64
+ license = Artistic
+ depends = boost
+ depends = eigen3
+ depends = python2
+ depends = samtools
+ depends = perl
+ source = http://cufflinks.cbcb.umd.edu/downloads/cufflinks-2.2.1.tar.gz
+
+pkgname = cufflinks
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f033b475f73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cufflinks
+ pkgdesc = Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples..
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://cufflinks.cbcb.umd.edu
+ arch = x86_64
+ license = Artistic
+ depends = boost
+ depends = eigen3
+ depends = python2
+ depends = samtools
+ depends = perl
+ source = http://cufflinks.cbcb.umd.edu/downloads/cufflinks-2.2.1.tar.gz
+ md5sums = 9a5ba7a7710cd864932cf205c17851f0
+
+pkgname = cufflinks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67d7d8fc8867
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thiago Yukio Kikuchi Oliveira <stratust@gmail.com>
+
+pkgname=cufflinks
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples.."
+arch=("x86_64")
+url="http://cufflinks.cbcb.umd.edu"
+license=('Artistic')
+depends=('boost' 'eigen3' 'python2' 'samtools' 'perl')
+source=(http://cufflinks.cbcb.umd.edu/downloads/$pkgname-$pkgver.tar.gz)
+md5sums=('9a5ba7a7710cd864932cf205c17851f0')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ # cufflinks use python2 but archlinux uses python3 as default python
+ perl -i -pne '$_ =~ s/python/python2/ if $_ =~ /^#!\/usr/' src/cuffmerge
+
+ export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
+ export LDFLAGS="-L/usr/lib -lboost_system"
+ ./configure --prefix=/usr
+ make
+
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}