summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Puntiy2013-04-08 22:29:42 +0300
committerIvan Puntiy2013-04-08 22:29:42 +0300
commit52596e2fe6802eb3f6704d7e759603ed0010c940 (patch)
tree229021f759c552b9cfcbca103689c56b984357bf
downloadaur-52596e2fe6802eb3f6704d7e759603ed0010c940.tar.gz
culmus 0.130-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--culmus-0.121-fontconfig_fix.patch203
-rw-r--r--culmus.install41
4 files changed, 305 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d844625c9d06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = culmus
+ pkgdesc = A collection of Type1 and TrueType Hebrew fonts
+ pkgver = 0.130
+ pkgrel = 1
+ url = http://culmus.sourceforge.net
+ install = culmus.install
+ arch = any
+ license = GPL2
+ depends = fontconfig
+ depends = xorg-fonts-alias
+ depends = xorg-font-utils
+ depends = xorg-fonts-encodings
+ source = http://downloads.sourceforge.net/culmus/culmus-0.130.tar.gz
+ source = culmus-0.121-fontconfig_fix.patch
+ md5sums = 58e672defde4caeae42017cd2f9436a6
+ md5sums = 6db715a072d9602a54c69a7e31a6428f
+
+pkgname = culmus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dd2c4247e91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ivan Puntiy <ivan.puntiy at gmail>
+# Contributor: <francois.archlinux.org>
+
+pkgname=culmus
+pkgver=0.130
+pkgrel=1
+pkgdesc="A collection of Type1 and TrueType Hebrew fonts"
+arch=('any')
+url="http://culmus.sourceforge.net"
+license=('GPL2')
+depends=('fontconfig' 'xorg-fonts-alias' 'xorg-font-utils' 'xorg-fonts-encodings')
+install=${pkgname}.install
+source=(
+ "http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "$pkgname-0.121-fontconfig_fix.patch"
+)
+md5sums=('58e672defde4caeae42017cd2f9436a6'
+ '6db715a072d9602a54c69a7e31a6428f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # fix due to fontconfig 2.10.1 update - patch mailed to upstream
+ patch culmus.conf "$srcdir/$pkgname-0.121-fontconfig_fix.patch"
+}
+
+package() {
+ # install Type1 fonts
+ install -d ${pkgdir}/usr/share/fonts/Type1
+ install -m644 ${srcdir}/culmus-$pkgver/*.{afm,pfa} \
+ ${pkgdir}/usr/share/fonts/Type1
+
+ # install ttf fonts
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install -m644 ${srcdir}/culmus-$pkgver/*.ttf \
+ ${pkgdir}/usr/share/fonts/TTF
+
+ # install provided config file with priority 61
+ install -d ${pkgdir}/etc/fonts/conf.avail/
+ install -m644 ${srcdir}/culmus-$pkgver/culmus.conf \
+ ${pkgdir}/etc/fonts/conf.avail/61-culmus.conf
+}
diff --git a/culmus-0.121-fontconfig_fix.patch b/culmus-0.121-fontconfig_fix.patch
new file mode 100644
index 000000000000..d303cbb09ec0
--- /dev/null
+++ b/culmus-0.121-fontconfig_fix.patch
@@ -0,0 +1,203 @@
+--- culmus.conf.original 2011-12-20 22:21:43.509488367 +0200
++++ culmus.conf.fixed 2012-09-09 21:14:42.401273058 +0300
+@@ -8,6 +8,17 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Guttman Adii</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>David CLM</string>
++ </edit>
++ <edit mode="assign" binding="same" name="slant" >
++ <const>italic</const>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Adii-Light</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -30,6 +41,14 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Guttman Stam</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Stam Ashkenaz CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Stam1</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -40,6 +59,14 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Guttman Hodes</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Hadasim CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Monotype Hadassah</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -50,7 +77,23 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Aharoni</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Aharoni CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Aharoni</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Aharoni CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman-Aharoni</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -61,7 +104,23 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>FrankRuehl</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Frank Ruehl CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Frank</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Frank Ruehl CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Frnew</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -72,7 +131,23 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>David</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>David CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>David Transparent</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>David CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman David</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -83,8 +158,32 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Fixed Miriam Transparent</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Miriam Mono CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Myamfix</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Miriam Mono CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman-CourMir</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Miriam Mono CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Miriam Fixed</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -95,8 +194,32 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Guttman Miryam</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Miriam CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Levenim MT</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Miriam CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Miriam</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Miriam CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Miriam Transparent</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
+@@ -107,6 +230,14 @@
+ <match target="pattern" >
+ <test name="family" >
+ <string>Guttman Drogolin</string>
++ </test>
++ <edit mode="append" binding="same" name="family" >
++ <string>Drugulin CLM</string>
++ </edit>
++ </match>
++
++ <match target="pattern" >
++ <test name="family" >
+ <string>Guttman Vilna</string>
+ </test>
+ <edit mode="append" binding="same" name="family" >
diff --git a/culmus.install b/culmus.install
new file mode 100644
index 000000000000..1376ca5cec82
--- /dev/null
+++ b/culmus.install
@@ -0,0 +1,41 @@
+configs=('61-culmus.conf')
+
+update_fontcache() {
+ fc-cache -fs
+ mkfontscale /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/Type1
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+}
+
+post_install() {
+ pushd /etc/fonts/conf.d > /dev/null
+ for config in "${configs[@]}"; do
+ ln -sf ../conf.avail/${config} .
+ done
+ popd > /dev/null
+
+ update_fontcache
+}
+
+post_upgrade() {
+ if [ "`vercmp 0.102-1 $2`" != "-1" ] || [ ! -L /etc/fonts/conf.d/61-culmus.conf ]; then
+ pushd /etc/fonts/conf.d > /dev/null
+ for config in "${configs[@]}"; do
+ ln -sf ../conf.avail/${config} .
+ done
+ popd > /dev/null
+ fi
+
+ update_fontcache
+}
+
+post_remove() {
+ pushd /etc/fonts/conf.d > /dev/null
+ for config in "${configs[@]}"; do
+ rm -f ${config}
+ done
+ popd > /dev/null
+
+ update_fontcache
+}