summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-09-11 20:06:54 +0800
committerChocobo12023-09-11 20:10:14 +0800
commite0da28f1dce03d42376ad0cfd70b996eaf776cf4 (patch)
tree6215b949245b28c28e9590a750ac859e4de2b864
downloadaur-e0da28f1dce03d42376ad0cfd70b996eaf776cf4.tar.gz
newpkg: cunit-svn r79-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab967149effd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cunit-svn
+ pkgdesc = A unit testing framework for C
+ pkgver = r170
+ pkgrel = 1
+ url = https://cunit.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = subversion
+ makedepends = libtool
+ depends = glibc
+ provides = cunit=r170
+ conflicts = cunit
+ options = staticlibs
+ source = svn+https://svn.code.sf.net/p/cunit/code/trunk
+ sha256sums = SKIP
+
+pkgname = cunit-svn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0739ede0257
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=cunit-svn
+pkgver=r170
+pkgrel=1
+pkgdesc="A unit testing framework for C"
+arch=('i686' 'x86_64')
+url="https://cunit.sourceforge.net/"
+license=('LGPL')
+depends=('glibc')
+makedepends=('subversion' 'libtool')
+provides=("cunit=$pkgver")
+conflicts=('cunit')
+options=('staticlibs')
+source=("svn+https://svn.code.sf.net/p/cunit/code/trunk")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "trunk"
+
+ _ver="$(svnversion)"
+ printf "r%s" "${_ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "trunk"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "trunk"
+
+ make check
+}
+
+package() {
+ cd "trunk"
+
+ make DESTDIR="$pkgdir" install
+}