summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-11-21 23:18:57 +0100
committerKr1ss2020-11-21 23:18:57 +0100
commita0659b59e127b6aaf37140d5fa0a08b585ee4bcf (patch)
treed7a16535a74a026527284b8c1857c553a1c93f87
downloadaur-a0659b59e127b6aaf37140d5fa0a08b585ee4bcf.tar.gz
initial upload: cupp-git 3.3.0.r77.56547fd-1
;------------------------------------------------|<← ;----------------------------------------------------------------------|<← ;----------------------------------------------------------------------|<← ;----------------------------------------------------------------------|<←
-rw-r--r--.SRCINFO16
-rw-r--r--CHANGELOG.md32
-rw-r--r--PKGBUILD48
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfb5ee501641
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cupp-git
+ pkgdesc = Common User Passwords Profiler
+ pkgver = 3.3.0.r77.56547fd
+ pkgrel = 1
+ url = https://github.com/Mebus/cupp
+ changelog = CHANGELOG.md
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ backup = etc/cupp.cfg
+ source = git+https://github.com/Mebus/cupp.git
+ sha256sums = SKIP
+
+pkgname = cupp-git
+
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..853d0a7667cc
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,32 @@
+# Changelog of CUPP
+
+All notable changes to this project will be documented in this file.
+This project adheres to [Semantic Versioning](http://semver.org/).
+
+## 3.2.0-alpha
+
+ - ran 2to3 on cupp.py to make it Python3 compatible
+
+## 3.1.0-alpha
+ - added Python3 port
+ - Bugfixes
+
+## 3.0.0
+ - added word length shaping function
+ - added wordlists downloader function
+ - added alectodb parser
+ - fixed thresholds for word concatenations
+ - fixed sorting in final parsing
+ - fixed some user input validations
+ - ascii cow now looks nicer :)
+
+## 2.0.0
+ - added l33t mode
+ - added char mode
+ - ability to make pwnsauce with other wordlists or wyd.pl outputs
+ - cupp.cfg makes cupp.py easier to configure
+
+
+## 1.0.0
+- Initial release
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ee97d73676b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer : Kr1ss $(tr +- .@ <<<'<kr1ss+x-yandex+com>')
+# Contributor : robertfoster
+
+
+pkgname=cupp-git
+_name="${pkgname%-git}"
+
+pkgver() {
+ cd "$_name"
+ printf '%s.r%s.%s' \
+ "$(grep ^__version__ "$_name.py" | sed 's/[^"]\+"\([^"]\+\)"/\1/')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgver=3.3.0.r77.56547fd
+pkgrel=1
+
+pkgdesc='Common User Passwords Profiler'
+url="https://github.com/Mebus/${pkgname%-git}"
+arch=('any')
+license=('GPL3')
+
+makedepends=('git')
+depends=('python')
+
+changelog=CHANGELOG.md
+backup=("etc/$_name.cfg")
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+
+build() {
+ python -O -m compileall "$_name"
+}
+
+package() {
+ cd "$_name"
+ install -Dm644 {README,CHANGELOG}.md -t"$pkgdir/usr/share/doc/$_name/"
+ install -Dm644 screenshots/* -t"$pkgdir/usr/share/doc/$_name/screenshots/"
+ install -Dm755 "$_name.py" -t"$pkgdir/usr/share/$_name/"
+ install -Dm644 __pycache__/* -t"$pkgdir/usr/share/$_name/__pycache__/"
+ install -Dm644 "$_name.cfg" -t"$pkgdir/etc/"
+ ln -sv "/etc/$_name.cfg" "$pkgdir/usr/share/$_name/"
+ install -dm755 "$pkgdir/usr/bin/"
+ ln -sv "/usr/share/$_name/$_name.py" "$pkgdir/usr/bin/$_name"
+}
+
+
+# vim: ts=2 sw=2 noet ft=PKGBUILD: