summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:29:54 +0200
committerM0Rf302015-06-17 15:29:54 +0200
commit81ce71e054b087ca5b6461ec70015859cb16a20d (patch)
tree7f5a6186eed6c7cfabf6a266fd9c1d60b8ec9d5b
downloadaur-81ce71e054b087ca5b6461ec70015859cb16a20d.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rwxr-xr-xcupp-bin4
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3a4ed469939
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cupp-v3
+ pkgdesc = Common User Passwords Profiler
+ pkgver = 3.0
+ pkgrel = 1
+ url = http://www.remote-exploit.org/?page_id=418
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ source = http://www.remote-exploit.org/content/cupp-3.0.tar.gz
+ source = cupp-bin
+ md5sums = d7bea1245095036a368566b9a15ddc86
+ md5sums = a44a6a199c7e80c926bffe95c1a5e8a7
+
+pkgname = cupp-v3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72848642c883
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: M0Rf30 <morf3089@gmail.com>
+
+pkgname=cupp-v3
+pkgver=3.0
+pkgrel=1
+pkgdesc="Common User Passwords Profiler "
+arch=('i686' 'x86_64')
+url="http://www.remote-exploit.org/?page_id=418"
+depends=('python2')
+license=('GPL')
+source=(http://www.remote-exploit.org/content/cupp-$pkgver.tar.gz
+ cupp-bin)
+
+package()
+{
+ # Organize the paths
+ mkdir -p $pkgdir/usr/share/
+ cp -r $srcdir/cupp $pkgdir/usr/share/
+
+ # Create the executable link
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/cupp-bin $pkgdir/usr/bin/cupp
+
+}
+
+md5sums=('d7bea1245095036a368566b9a15ddc86'
+ 'a44a6a199c7e80c926bffe95c1a5e8a7')
diff --git a/cupp-bin b/cupp-bin
new file mode 100755
index 000000000000..65403138be52
--- /dev/null
+++ b/cupp-bin
@@ -0,0 +1,4 @@
+#!/bin/bash
+cd /usr/share/cupp
+python2 -E cupp.py $@
+