summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXunhua Guo2022-05-27 17:07:11 +0800
committerXunhua Guo2022-05-27 17:07:11 +0800
commit04b2e3f58a442e9110c6cb12e20acfd24f45f35a (patch)
tree1a43875caa21d28ce842fb38ad219695a6e67678
parentd2c0394f9addecef80bc8753c1b7c6f60c6fac8b (diff)
downloadaur-04b2e3f58a442e9110c6cb12e20acfd24f45f35a.tar.gz
Disable LTO to suppress some compilation errors.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7308b779c95c..6cbd73d3f8dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cups-bjnp
pkgdesc = CUPS back-end for the canon printers using the proprietary USB over IP BJNP protocol
pkgver = 2.0.3
- pkgrel = 2
+ pkgrel = 3
url = http://sourceforge.net/projects/cups-bjnp/
arch = i686
arch = x86_64
license = GPL
makedepends = cups
depends = libcups
+ options = !lto
source = http://downloads.sourceforge.net/sourceforge/cups-bjnp/cups-bjnp-2.0.3.tar.gz
sha256sums = c914b2fd9d8e26ce22f2df6244d9defeec31ee9a5360f723eecb3b00f2168500
diff --git a/PKGBUILD b/PKGBUILD
index adde4c9f047c..9482bb6d8260 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=cups-bjnp
pkgver=2.0.3
-pkgrel=2
+pkgrel=3
pkgdesc='CUPS back-end for the canon printers using the proprietary USB over IP BJNP protocol'
arch=('i686' 'x86_64')
url='http://sourceforge.net/projects/cups-bjnp/'
@@ -14,6 +14,8 @@ depends=('libcups')
makedepends=('cups')
source=("http://downloads.sourceforge.net/sourceforge/cups-bjnp/cups-bjnp-${pkgver}.tar.gz")
sha256sums=('c914b2fd9d8e26ce22f2df6244d9defeec31ee9a5360f723eecb3b00f2168500')
+# Disable LTO to suppress some compilation errors.
+options=("!lto")
build() {
cd cups-bjnp-${pkgver}
@@ -21,6 +23,7 @@ build() {
# Patch for https://gcc.gnu.org/onlinedocs/gcc-8.1.0/gcc/Warning-Options.html#index-Wstringop_002dtruncation
# sed -i 's/strncpy/memcpy/' bjnp-commands.c
+ # Remove always-true comparison '(printer_id != NULL)'
sed -i '188d;191d' bjnp-commands.c
./configure --prefix='/usr'