summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkythrew2023-05-25 17:28:13 +0200
committerSkythrew2023-05-25 17:28:13 +0200
commit7f78a818b6cc9ad8cb24cab83ccf788a329b73e6 (patch)
tree9f6064789180f1bb40910bfcd9fda772c853b0eb
parent04b2e3f58a442e9110c6cb12e20acfd24f45f35a (diff)
downloadaur-7f78a818b6cc9ad8cb24cab83ccf788a329b73e6.tar.gz
Fix storing address of local variable
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9482bb6d8260..26e33f998995 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,6 +26,9 @@ build() {
# Remove always-true comparison '(printer_id != NULL)'
sed -i '188d;191d' bjnp-commands.c
+ # Fix storing address of local variable "in" in "next"
+ sed -e 's/next = in/strcpy(next, in)/' -i bjnp-levels.c
+
./configure --prefix='/usr'
make
}