summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Hebrok2024-01-04 11:26:07 +0100
committerSven Hebrok2024-01-04 11:26:07 +0100
commit21eac385224fc5e67e2e5dd1ca0cc8d6238e92af (patch)
tree5a6589137adced0a2d0b89bfa0bd9c9c86790204
parentb99e02fc3c653fe8c85a7ca5f9d375d3c7286c2a (diff)
downloadaur-cups-gssapi.tar.gz
Update to 2.4.7-2
Improve logging a bit Pull new archlinux docker image to ensure it is not tested on an old image
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD9
-rwxr-xr-x_create_package.sh12
-rwxr-xr-x_docker_validate.sh2
4 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d47779f4f16f..344a38ea6fe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cups-gssapi
- pkgver = 2.4.6
- pkgrel = 1
+ pkgver = 2.4.7
+ pkgrel = 2
epoch = 1
url = https://openprinting.github.io/cups/
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = cups-gssapi
makedepends = avahi
makedepends = systemd
makedepends = libpaper
- source = https://github.com/OpenPrinting/cups/releases/download/v2.4.6/cups-2.4.6-source.tar.gz
- source = https://github.com/OpenPrinting/cups/releases/download/v2.4.6/cups-2.4.6-source.tar.gz.sig
+ source = https://github.com/OpenPrinting/cups/releases/download/v2.4.7/cups-2.4.7-source.tar.gz
+ source = https://github.com/OpenPrinting/cups/releases/download/v2.4.7/cups-2.4.7-source.tar.gz.sig
source = cups.logrotate
source = cups.pam
source = cups.sysusers
@@ -24,7 +24,7 @@ pkgbase = cups-gssapi
source = cups-freebind.patch
source = guid.patch
validpgpkeys = 7082A0A50A2E92640F3880E0E4522DCC9B246FF7
- sha256sums = 58e970cf1955e1cc87d0847c32526d9c2ccee335e5f0e3882b283138ba0e7262
+ sha256sums = dd54228dd903526428ce7e37961afaed230ad310788141da75cebaa08362cf6c
sha256sums = SKIP
sha256sums = d87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9
sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
@@ -40,7 +40,7 @@ pkgname = libcups-gssapi
depends = glibc
depends = zlib
depends = krb5
- provides = libcups=2.4.6
+ provides = libcups=2.4.7
conflicts = libcups
pkgname = cups-gssapi
@@ -48,7 +48,7 @@ pkgname = cups-gssapi
install = cups.install
depends = acl
depends = pam
- depends = libcups>=2.4.6
+ depends = libcups>=2.4.7
depends = cups-filters
depends = dbus
depends = systemd
@@ -59,6 +59,7 @@ pkgname = cups-gssapi
depends = gcc-libs
depends = avahi
depends = gnutls
+ optdepends = cups-browsed: to browse the network for remote CUPS queues and IPP network printers
optdepends = libusb: for usb printer backend
optdepends = ipp-usb: allows to send HTTP requests via a USB connection on devices without Ethernet or WiFi connections
optdepends = xdg-utils: xdg .desktop file support
diff --git a/PKGBUILD b/PKGBUILD
index 7f313b753c76..03ea237f0b97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgbase="cups-gssapi"
pkgname=('libcups-gssapi' 'cups-gssapi')
-pkgver=2.4.6
-pkgrel=1
+pkgver=2.4.7
+pkgrel=2
epoch=1
arch=('x86_64')
license=('Apache' 'custom')
@@ -23,7 +23,7 @@ source=(https://github.com/OpenPrinting/cups/releases/download/v${pkgver}/cups-$
cups-freebind.patch
guid.patch
)
-sha256sums=('58e970cf1955e1cc87d0847c32526d9c2ccee335e5f0e3882b283138ba0e7262'
+sha256sums=('dd54228dd903526428ce7e37961afaed230ad310788141da75cebaa08362cf6c'
'SKIP'
'd87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9'
'57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
@@ -127,7 +127,8 @@ backup=(etc/cups/cupsd.conf
depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters'
'dbus' 'systemd' 'systemd-libs' 'libpaper' 'hicolor-icon-theme'
'glibc' 'gcc-libs' 'avahi' 'gnutls')
-optdepends=('libusb: for usb printer backend'
+optdepends=('cups-browsed: to browse the network for remote CUPS queues and IPP network printers'
+ 'libusb: for usb printer backend'
'ipp-usb: allows to send HTTP requests via a USB connection on devices without Ethernet or WiFi connections'
'xdg-utils: xdg .desktop file support'
'colord: for ICC color profile support'
diff --git a/_create_package.sh b/_create_package.sh
index 12bcc1944c29..c8ae6a55a40a 100755
--- a/_create_package.sh
+++ b/_create_package.sh
@@ -6,27 +6,35 @@ shopt -s extglob
# cleanup
if [ -d cups ]; then
+ echo "[ ] Removing old cups directory"
rm -r cups
fi
if ls !("_create_package.sh"|"_patch.sed"|"_docker_validate.sh") >/dev/null 2>/dev/null; then
+ echo "[ ] Removing old files (except ours)"
rm -r !("_create_package.sh"|"_patch.sed"|"_docker_validate.sh")
fi
-# get upstream cups package
+echo "[ ] Cloning cups"
pkgctl repo clone --protocol=https cups
+echo "[#] Cloned cups"
rm -rf cups/.git/
mv cups/* ./
rmdir cups
# apply our patches
+echo "[ ] Applying patches"
sed -Ef _patch.sed -i PKGBUILD
+echo "[#] Applied patches"
# seemingly the AUR does not like subdirectories
-rm -r -- */
+echo "[ ] Removing subdirectories"
+rm -vr -- */
# update metadata
+echo "[ ] Updating metadata"
makepkg --printsrcinfo > .SRCINFO
echo "[ ] Validating package using docker"
+docker pull archlinux
docker run --rm -e MAKEFLAGS -v "$(pwd):/source:ro" archlinux /source/_docker_validate.sh || (echo "[!] Failed to validate package using docker" && exit 1)
echo "[#] Validated package using docker"
diff --git a/_docker_validate.sh b/_docker_validate.sh
index 9e5d31b64b56..057d39b00b32 100755
--- a/_docker_validate.sh
+++ b/_docker_validate.sh
@@ -5,7 +5,9 @@ if ! [ -f '/source/_docker_validate.sh' ]; then
exit 1
fi
if [ "$EUID" = 0 ]; then
+ echo "[ ] Installing required build tools"
pacman -Sy --needed --noconfirm base-devel
+ echo "[ ] Creating builduser"
useradd builduser -m # Create the builduser
passwd -d builduser # Delete the buildusers password
printf 'builduser ALL=(ALL) ALL\n' | tee -a /etc/sudoers # Allow the builduser passwordless sudo