summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Hebrok2023-06-27 11:13:47 +0200
committerSven Hebrok2023-06-27 11:13:47 +0200
commitb99e02fc3c653fe8c85a7ca5f9d375d3c7286c2a (patch)
tree29beffe2f76ab6f5f798e33a48857fdb7d6aa712
parentd86bdd564d29f2337f7f814e3474e431cc7a090b (diff)
downloadaur-b99e02fc3c653fe8c85a7ca5f9d375d3c7286c2a.tar.gz
Update to 2.4.6; Remove cups-filters as make dependency
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD6
-rwxr-xr-x_docker_validate.sh2
-rw-r--r--_patch.sed3
4 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c69706831bb..d47779f4f16f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = cups-gssapi
- pkgver = 2.4.5
+ pkgver = 2.4.6
pkgrel = 1
epoch = 1
url = https://openprinting.github.io/cups/
@@ -9,15 +9,14 @@ pkgbase = cups-gssapi
makedepends = acl
makedepends = pam
makedepends = gnutls
- makedepends = cups-filters
makedepends = colord
makedepends = krb5
makedepends = libusb
makedepends = avahi
makedepends = systemd
makedepends = libpaper
- source = https://github.com/OpenPrinting/cups/releases/download/v2.4.5/cups-2.4.5-source.tar.gz
- source = https://github.com/OpenPrinting/cups/releases/download/v2.4.5/cups-2.4.5-source.tar.gz.sig
+ source = https://github.com/OpenPrinting/cups/releases/download/v2.4.6/cups-2.4.6-source.tar.gz
+ source = https://github.com/OpenPrinting/cups/releases/download/v2.4.6/cups-2.4.6-source.tar.gz.sig
source = cups.logrotate
source = cups.pam
source = cups.sysusers
@@ -25,7 +24,7 @@ pkgbase = cups-gssapi
source = cups-freebind.patch
source = guid.patch
validpgpkeys = 7082A0A50A2E92640F3880E0E4522DCC9B246FF7
- sha256sums = 9a404de55f74525b0a6851df0cfdebfa1215aec0e7c2f7be6b9b09b6916fb000
+ sha256sums = 58e970cf1955e1cc87d0847c32526d9c2ccee335e5f0e3882b283138ba0e7262
sha256sums = SKIP
sha256sums = d87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9
sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
@@ -41,7 +40,7 @@ pkgname = libcups-gssapi
depends = glibc
depends = zlib
depends = krb5
- provides = libcups=2.4.5
+ provides = libcups=2.4.6
conflicts = libcups
pkgname = cups-gssapi
@@ -49,7 +48,7 @@ pkgname = cups-gssapi
install = cups.install
depends = acl
depends = pam
- depends = libcups>=2.4.5
+ depends = libcups>=2.4.6
depends = cups-filters
depends = dbus
depends = systemd
diff --git a/PKGBUILD b/PKGBUILD
index b07a697d7f61..7f313b753c76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgbase="cups-gssapi"
pkgname=('libcups-gssapi' 'cups-gssapi')
-pkgver=2.4.5
+pkgver=2.4.6
pkgrel=1
epoch=1
arch=('x86_64')
license=('Apache' 'custom')
url="https://openprinting.github.io/cups/"
-makedepends=('acl' 'pam' 'gnutls' 'cups-filters' 'colord'
+makedepends=('acl' 'pam' 'gnutls' 'colord'
'krb5'
'libusb' 'avahi' 'systemd' 'libpaper')
#checkdepends=('valgrind')
@@ -23,7 +23,7 @@ source=(https://github.com/OpenPrinting/cups/releases/download/v${pkgver}/cups-$
cups-freebind.patch
guid.patch
)
-sha256sums=('9a404de55f74525b0a6851df0cfdebfa1215aec0e7c2f7be6b9b09b6916fb000'
+sha256sums=('58e970cf1955e1cc87d0847c32526d9c2ccee335e5f0e3882b283138ba0e7262'
'SKIP'
'd87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9'
'57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
diff --git a/_docker_validate.sh b/_docker_validate.sh
index c446c69bac10..9e5d31b64b56 100755
--- a/_docker_validate.sh
+++ b/_docker_validate.sh
@@ -17,5 +17,5 @@ else
cp -r /source build
cd build
echo "[ ] Starting to build"
- makepkg -risc --noconfirm
+ makepkg -isc --noconfirm
fi
diff --git a/_patch.sed b/_patch.sed
index 5926545a7d8e..4a8ff27d8aaf 100644
--- a/_patch.sed
+++ b/_patch.sed
@@ -30,5 +30,8 @@ s/.\/configure (.+) \\/.\/configure \1 --enable-gssapi --with-cups-build="cups-g
# fix usage of "${pkgbase}"
s/\$\{pkgbase\}/cups/g
+# remove cups-filters make dependency as it is just causing trouble, and should only be a post-install dependency (already is for cups, not for libcups)
+/^makedepends=/ s/'cups-filters' //
+
# if we do more patches, use this to update pkgrel:
# s/pkgrel=3/pkgrel=3.2/