summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Redden2015-06-16 10:48:58 -0400
committerChris Redden2015-06-16 10:48:58 -0400
commit7a879b4054585e6584f73d22f964ba07b75aaaff (patch)
tree2b6eab486901c38e57fbb1304aac751154786a2e
downloadaur-7a879b4054585e6584f73d22f964ba07b75aaaff.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--cups-pdf.install16
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4aa4c700eb1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cups-pdf-beta
+ pkgdesc = PDF printer for cups (beta)
+ pkgver = 3.0beta2
+ pkgrel = 1
+ url = http://www.cups-pdf.de/
+ install = cups-pdf.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = cups
+ depends = ghostscript
+ provides = cups-pdf=3.0beta2
+ conflicts = cups-pdf
+ backup = etc/cups/cups-pdf.conf
+ source = http://www.cups-pdf.de/src/cups-pdf_3.0beta2.tar.gz
+ md5sums = fabfa3a96551a7dd2c466f8b120c13a5
+
+pkgname = cups-pdf-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2c2d98f4ae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: redden0t8 -- contact via Arch Linux forums or AUR
+#
+# PKGBUILD based off of official cups-pdf package
+#
+# Official package credit:
+# Maintainer: Andreas Radke <andyrtr at archlinux.org>
+# Contributor: Thomas Baechler <thomas.baechler@rwth-aachen.de>
+
+pkgname=cups-pdf-beta
+pkgver=3.0beta2
+pkgrel=1
+pkgdesc="PDF printer for cups (beta)"
+arch=(i686 x86_64)
+depends=('cups' 'ghostscript')
+provides=("cups-pdf=${pkgver}")
+conflicts=('cups-pdf')
+install=cups-pdf.install
+url="http://www.cups-pdf.de/"
+license=('GPL2')
+source=("http://www.cups-pdf.de/src/cups-pdf_${pkgver}.tar.gz")
+backup=(etc/cups/cups-pdf.conf)
+md5sums=('fabfa3a96551a7dd2c466f8b120c13a5')
+
+build() {
+ cd $srcdir/cups-pdf-$pkgver/src
+ [ -z "$CC" ] && CC=gcc
+ $CC $CFLAGS -lcups -Wall -o cups-pdf cups-pdf.c
+}
+
+package() {
+ cd $srcdir/cups-pdf-$pkgver/src
+ install -D -m700 cups-pdf $pkgdir/usr/lib/cups/backend/cups-pdf
+
+ # Install Postscript Color printer
+ cd ../extra
+ install -D -m644 CUPS-PDF_noopt.ppd $pkgdir/usr/share/cups/model/CUPS-PDF.ppd
+
+ # Install config file
+ install -D -m644 cups-pdf.conf $pkgdir/etc/cups/cups-pdf.conf
+
+ # use lp group from cups pkg FS#36769
+ chgrp -R lp ${pkgdir}/etc/cups
+}
diff --git a/cups-pdf.install b/cups-pdf.install
new file mode 100644
index 000000000000..7df03c811015
--- /dev/null
+++ b/cups-pdf.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat << "EOF"
+-------------------------------------------------
+To use cups-pdf, restart cups and visit the cups
+web interface at http://localhost:631/
+
+You can now add a "Virtual Printer (PDF Printer)"
+and use the Postscript/Generic postscript color
+printer driver.
+
+Note that cups-pdf has a configuration
+file in /etc/cups. The default location for
+pdf output is /var/spool/cups-pdf/$username.
+-------------------------------------------------
+EOF
+}