summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoeljunior2018-01-20 16:38:16 +0000
committerNoeljunior2018-01-20 16:38:16 +0000
commit72aed0cdaed95f8de230f169938cd06a50e13e3d (patch)
treed4115e10737d4a14aaa08b10891edce20d7597a7
downloadaur-72aed0cdaed95f8de230f169938cd06a50e13e3d.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87559ddd4e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cups-pdf-to-pdf-git
+ pkgdesc = CUPS-PDF v3 with text print support
+ pkgver = 3.0.1_r7.63ab5e7
+ pkgrel = 1
+ url = https://github.com/alexivkin/CUPS-PDF-to-PDF
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = cups
+ depends = ghostscript
+ provides = cups-pdf=3.0.1_r7.63ab5e7
+ conflicts = cups-pdf
+ backup = etc/cups/cups-pdf.conf
+ source = cups-pdf-to-pdf-git::git+https://github.com/alexivkin/CUPS-PDF-to-PDF
+ md5sums = SKIP
+
+pkgname = cups-pdf-to-pdf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..150e5e0a35ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Noeljnuior <liamgliamgmailcom>
+# Contributor: redden0t8 -- contact via Arch Linux forums or AUR
+# Contributor: Andreas Radke <andyrtr at archlinux.org>
+# Contributor: Thomas Baechler <thomas.baechler@rwth-aachen.de>
+
+pkgname=cups-pdf-to-pdf-git
+pkgver=3.0.1_r7.63ab5e7
+uppkgver=3.0.1
+pkgrel=1
+pkgdesc="CUPS-PDF v3 with text print support"
+arch=(i686 x86_64)
+depends=('cups' 'ghostscript')
+provides=("cups-pdf=${pkgver}")
+conflicts=('cups-pdf')
+url="https://github.com/alexivkin/CUPS-PDF-to-PDF"
+license=('GPL2')
+source=("$pkgname::git+https://github.com/alexivkin/CUPS-PDF-to-PDF")
+backup=(etc/cups/cups-pdf.conf)
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname/"
+ [ -z "$CC" ] && CC=gcc
+ $CC $CFLAGS -lcups -Wall -o cups-pdf cups-pdf.c
+ echo CFLAGS $CFLAGS
+}
+
+package() {
+ cd "$srcdir/$pkgname/"
+ install -D -m700 cups-pdf $pkgdir/usr/lib/cups/backend/cups-pdf
+
+ # Install Postscript Color printer
+ install -D -m644 CUPS-PDF_opt.ppd $pkgdir/usr/share/cups/model/CUPS-PDF_opt.ppd
+ install -D -m644 CUPS-PDF_noopt.ppd $pkgdir/usr/share/cups/model/CUPS-PDF_noopt.ppd
+
+ # Install config file & use lp group from cups pkg
+ install -D -m644 -g lp cups-pdf.conf $pkgdir/etc/cups/cups-pdf.conf
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname/"
+ printf "%s_r%s.%s" "$uppkgver" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}