aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-05-22 12:02:59 +0200
committerfelics2018-05-22 12:02:59 +0200
commit1b0e7f486fe7a31a5d65489eda3eef442b2b5abd (patch)
tree6e8fa0c119d9ee7ce31263adfb560eb72d1777bc
parent153aad2e8269ab5008c314c0390a329d4638ceaf (diff)
downloadaur-1b0e7f486fe7a31a5d65489eda3eef442b2b5abd.tar.gz
Minor bugfix.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rwxr-xr-xcups-programme.sh4
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75979dafe22f..bad9189968a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cups-print-to-programme
pkgdesc = Virtual printer for cups which prints to a file and opens that with a programme the user can choose in the settings. For example, print to gimp.
- pkgver = 0.2
- pkgrel = 2
+ pkgver = 0.2.1
+ pkgrel = 1
url = http://felics.kettenbruch.de/software/cups-print-to-programme/
install = cups-programme.install
arch = any
@@ -20,7 +20,7 @@ pkgbase = cups-print-to-programme
optdepends = seahorse: For a graphical password input frontend for sudo.
optdepends = ksshaskpass: For a graphical password input frontend for sudo.
optdepends = gnome-ssh-askpass2: For a graphical password input frontend for sudo.
- provides = cups-print-to-programme-doc=0.2
+ provides = cups-print-to-programme-doc=0.2.1
backup = etc/cups/cups-programme.conf
source = cups-programme.sh
source = cups-programme.conf
@@ -28,7 +28,7 @@ pkgbase = cups-print-to-programme
source = TODO.txt
source = GPL3.txt
source = cups-programme.install
- sha256sums = 2254436c330f7cbaf90dc4f3572ae670893520ae7ae9af48dcb5be28ae7cb89b
+ sha256sums = 9e29f33db3bf8c4697034db0a16e869a5db16b9306243bce5e5a54bece7b0296
sha256sums = f583ed8969deef9e890b20c475bc24fd4eed8ef3c3a51544f9183fcc69d38c5c
sha256sums = 9dab3a743d524aa3c6992501205ee7be4baaff3f73534ef878162e4e603bc9ca
sha256sums = 83b54a69c67d39d03b1b02a4da1c2bccb45c459f239809568221844c2e7500a7
diff --git a/PKGBUILD b/PKGBUILD
index bc685dcc46bf..7544019938db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=cups-print-to-programme
pkgname="${_pkgname}"
-pkgver=0.2
-pkgrel=2
+pkgver=0.2.1
+pkgrel=1
pkgdesc="Virtual printer for cups which prints to a file and opens that with a programme the user can choose in the settings. For example, print to gimp."
arch=('any')
depends=(
@@ -38,7 +38,7 @@ optdepends=(
)
provides=("${_pkgname}-doc=${pkgver}")
backup=('etc/cups/cups-programme.conf')
-sha256sums=('2254436c330f7cbaf90dc4f3572ae670893520ae7ae9af48dcb5be28ae7cb89b'
+sha256sums=('9e29f33db3bf8c4697034db0a16e869a5db16b9306243bce5e5a54bece7b0296'
'f583ed8969deef9e890b20c475bc24fd4eed8ef3c3a51544f9183fcc69d38c5c'
'9dab3a743d524aa3c6992501205ee7be4baaff3f73534ef878162e4e603bc9ca'
'83b54a69c67d39d03b1b02a4da1c2bccb45c459f239809568221844c2e7500a7'
@@ -46,6 +46,7 @@ sha256sums=('2254436c330f7cbaf90dc4f3572ae670893520ae7ae9af48dcb5be28ae7cb89b'
'0ee996783ae6848cf3c522de135646cb4b19670a48d6f1bf387b5b304f5506ad')
+
pkgver() {
cd "${srcdir}"
./cups-programme.sh --version
diff --git a/cups-programme.sh b/cups-programme.sh
index acf0e52dc813..58ade12035c0 100755
--- a/cups-programme.sh
+++ b/cups-programme.sh
@@ -29,7 +29,7 @@
#
# The version.
-VERSION=0.2
+VERSION=0.2.1
# Abort on error
set -e
@@ -292,7 +292,7 @@ parse_argv() {
shift
done
}
-log_local "Parsing options from DEVICE_URI: ${argv@Q} ..."
+log_local "Parsing options from DEVICE_URI: ${argv[@]@Q} ..."
parse_argv "${argv[@]}"
log_local "Parsed options."
log_local ""