summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSýlvan Heuser2017-03-10 15:19:33 +0100
committerSýlvan Heuser2017-03-10 15:19:33 +0100
commit8cd074c4e28d0d8aac1071197b763af0ea2cf0f2 (patch)
tree02bc379aeccd95b2fa5e6a470b674db7513bb3b7
parentc105e97d993bd25f3ca8a00be2d4ae430e08d910 (diff)
downloadaur-8cd074c4e28d0d8aac1071197b763af0ea2cf0f2.tar.gz
Rewrite to Xerox Phaser 3600
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD47
3 files changed, 39 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8ec504163dc..c8a2dc165614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Dec 21 14:29:23 UTC 2015
-pkgbase = cups-xerox-phaser-3160
- pkgdesc = CUPS driver for the Xerox Phaser 3160 series
- pkgver = 1.0.0
+# Fri Mar 10 14:15:29 UTC 2017
+pkgbase = cups-xerox-phaser-3600
+ pkgdesc = CUPS driver for the Xerox Phaser 3600 series. Also supports fc2218, pe120, pe220, Phaser 3117, 3200, 3250, 3250, 3300, 3435, 3600, 6110, WorkCentre 3210, 3220, 4118
+ pkgver = 3.00.27+187
pkgrel = 1
- url = http://www.support.xerox.com/support/phaser-3160/downloads/engb.html?operatingSystem=linux
+ url = http://www.support.xerox.com/support/phaser-3600/downloads/enus.html?operatingSystem=linux
arch = i686
arch = x86_64
license = custom
depends = cups
- source = http://download.support.xerox.com/pub/drivers/3160/drivers/linux/bg/P3160.tar.gz
- sha256sums = f03aea137b7797f5bf098f1142d24a1f24e11fa47e0c6addd026ec5707ea4ffd
+ source = http://download.support.xerox.com/pub/drivers/3600/drivers/linux/fr_CA/P3600.tar.gz
+ sha256sums = 8622a96290080f86c4c3b002c1a6c82d2c4dc4ede0e383dc86d83b6e4a8064c2
-pkgname = cups-xerox-phaser-3160
+pkgname = cups-xerox-phaser-3600
diff --git a/.gitignore b/.gitignore
index 190417929c63..f71c635dafda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
-/P3160.tar.gz
-*.tar.xz
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index bf0e0c5094df..4bc7ba1c0291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,41 @@
-# Maintainer: Joshua Ellis <josh@jpellis.me>
+# Maintainer: Sýlvan Heuser <sylvan.heuser@gmx.net>
+# Contributor: Joshua Ellis <josh@jpellis.me>
-pkgname=cups-xerox-phaser-3160
-pkgver=1.0.0
+pkgname=cups-xerox-phaser-3600
+pkgver=3.00.27+187
pkgrel=1
-_rpmname=Xerox-Phaser-3160-Linux.rpm
-pkgdesc="CUPS driver for the Xerox Phaser 3160 series"
-url="http://www.support.xerox.com/support/phaser-3160/downloads/engb.html?operatingSystem=linux"
+pkgdesc="CUPS driver for the Xerox Phaser 3600 series. Also supports fc2218, pe120, pe220, Phaser 3117, 3200, 3250, 3250, 3300, 3435, 3600, 6110, WorkCentre 3210, 3220, 4118"
+url="http://www.support.xerox.com/support/phaser-3600/downloads/enus.html?operatingSystem=linux"
license=('custom')
arch=('i686' 'x86_64')
depends=('cups')
-source=("http://download.support.xerox.com/pub/drivers/3160/drivers/linux/bg/P3160.tar.gz")
-sha256sums=('f03aea137b7797f5bf098f1142d24a1f24e11fa47e0c6addd026ec5707ea4ffd')
+source=("http://download.support.xerox.com/pub/drivers/3600/drivers/linux/fr_CA/P3600.tar.gz")
+sha256sums=('8622a96290080f86c4c3b002c1a6c82d2c4dc4ede0e383dc86d83b6e4a8064c2')
+
+pkgver () {
+ cd "${srcdir}/media/P3600/Linux/noarch/at_opt/share"
+ echo $(cat VERSION-Printer_LINUX)+$(cat VERSION-BUILD)
+}
+
+prepare () {
+ chmod -R u+w "${srcdir}"
+}
package() {
- chmod -R u+w ${srcdir}
- cd ${srcdir}/media/P3160/Linux
+ arch_dir="$CARCH"
if [[ "$CARCH" == "i686" ]]; then
- cp -r i386/at_root/usr ${pkgdir}/.
- cp -r i386/at_opt/lib ${pkgdir}/usr/.
- elif [[ "$CARCH" == "x86_64" ]]; then
- cp -r x86_64/at_root/usr ${pkgdir}/.
+ arch_dir="i386"
+ fi
+
+ cd "${srcdir}/media/P3600/Linux"
+ cp -a "${arch_dir}/at_root/usr" "${pkgdir}/"
+ cp -a "${arch_dir}/at_opt/lib" "${pkgdir}/usr/"
+ if [[ "$CARCH" == "x86_64" ]]; then
mv ${pkgdir}/usr/lib64 ${pkgdir}/usr/lib
- cp -r x86_64/at_opt/lib ${pkgdir}/usr/.
fi
mkdir ${pkgdir}/usr/share
- cp -r noarch/at_opt/share/ppd ${pkgdir}/usr/share/.
+ cp -a noarch/at_opt/share/ppd ${pkgdir}/usr/share/
rm -rf ${pkgdir}/usr/sbin
}
-
-# Local Variables:
-# mode: sh
-# End:
+# vim:set ts=2 sw=2 et: