summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2015-12-22 01:29:39 +1100
committerJP-Ellis2015-12-22 01:29:39 +1100
commitc105e97d993bd25f3ca8a00be2d4ae430e08d910 (patch)
tree22897ed759188e91e33fd2b96c621c8afcd926b7
downloadaur-c105e97d993bd25f3ca8a00be2d4ae430e08d910.tar.gz
Initial commit.
Signed-off-by: JP-Ellis <coujellis@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD34
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8ec504163dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 14:29:23 UTC 2015
+pkgbase = cups-xerox-phaser-3160
+ pkgdesc = CUPS driver for the Xerox Phaser 3160 series
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.support.xerox.com/support/phaser-3160/downloads/engb.html?operatingSystem=linux
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = cups
+ source = http://download.support.xerox.com/pub/drivers/3160/drivers/linux/bg/P3160.tar.gz
+ sha256sums = f03aea137b7797f5bf098f1142d24a1f24e11fa47e0c6addd026ec5707ea4ffd
+
+pkgname = cups-xerox-phaser-3160
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..190417929c63
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/P3160.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf0e0c5094df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Joshua Ellis <josh@jpellis.me>
+
+pkgname=cups-xerox-phaser-3160
+pkgver=1.0.0
+pkgrel=1
+_rpmname=Xerox-Phaser-3160-Linux.rpm
+pkgdesc="CUPS driver for the Xerox Phaser 3160 series"
+url="http://www.support.xerox.com/support/phaser-3160/downloads/engb.html?operatingSystem=linux"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('cups')
+source=("http://download.support.xerox.com/pub/drivers/3160/drivers/linux/bg/P3160.tar.gz")
+sha256sums=('f03aea137b7797f5bf098f1142d24a1f24e11fa47e0c6addd026ec5707ea4ffd')
+
+package() {
+ chmod -R u+w ${srcdir}
+ cd ${srcdir}/media/P3160/Linux
+ if [[ "$CARCH" == "i686" ]]; then
+ cp -r i386/at_root/usr ${pkgdir}/.
+ cp -r i386/at_opt/lib ${pkgdir}/usr/.
+ elif [[ "$CARCH" == "x86_64" ]]; then
+ cp -r x86_64/at_root/usr ${pkgdir}/.
+ mv ${pkgdir}/usr/lib64 ${pkgdir}/usr/lib
+ cp -r x86_64/at_opt/lib ${pkgdir}/usr/.
+ fi
+ mkdir ${pkgdir}/usr/share
+ cp -r noarch/at_opt/share/ppd ${pkgdir}/usr/share/.
+ rm -rf ${pkgdir}/usr/sbin
+}
+
+
+# Local Variables:
+# mode: sh
+# End: