summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormichael.gruz2022-10-02 22:09:29 +0200
committermichael.gruz2022-10-02 22:09:29 +0200
commit981dfae6cb63bdc88127b6224444e5dbe30039ab (patch)
tree28e0a94cc00f08d50c98099778ee0c7ebbf6ca87
downloadaur-981dfae6cb63bdc88127b6224444e5dbe30039ab.tar.gz
First release.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--cura.desktop.patch31
-rwxr-xr-xcura5.sh6
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257cbd614e31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cura-5-beta-bin
+ pkgdesc = Uncompressed version of Ultimaker Cura 5.2
+ pkgver = 5.2.0
+ pkgrel = 0
+ url = https://ultimaker.com/software/ultimaker-cura
+ arch = x86_64
+ license = LGPL3
+ depends = xdg-desktop-portal
+ depends = xdg-desktop-portal-gtk
+ optdepends = cura-5-plugin-octoprint: Cura plugin which enables printing directly to OctoPrint and monitoring the progress
+ optdepends = cura-5-plugin-octoprint-git: Cura plugin which enables printing directly to OctoPrint and monitoring the progress
+ provides = cura
+ conflicts = cura-5-bin
+ options = !strip
+ source = https://github.com/Ultimaker/Cura/releases/download/5.2.0-beta/Ultimaker-Cura-5.2.0-beta-linux.AppImage
+ source = cura5.sh
+ source = cura.desktop.patch
+ sha256sums = 77f13c5fb9c0582b283a122498f3a97339738b03b626d51a4fe13c2304502bda
+ sha256sums = f7917a834849618f62147bf68e8cb1cb31157e724163325effd495ddd8be2494
+ sha256sums = 22ee374746989baa4f87e79ecbc662b681ba9ca3fd93902408367461a2b4b571
+
+pkgname = cura-5-beta-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1de7f1be2ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Nestor Cagnoli <nestor[DOT]cagnoli[at]gmail[DOT]com>
+# Maintainer: Michael Gruz <michael.gruz@gmail.com>
+pkgname=cura-5-beta-bin
+_pkgname=cura-5-beta-bin
+_shortname=cura5
+pkgver=5.2.0
+pkgrel=0
+pkgdesc='Uncompressed version of Ultimaker Cura 5.2'
+arch=('x86_64')
+url="https://ultimaker.com/software/ultimaker-cura"
+license=('LGPL3')
+depends=('xdg-desktop-portal' 'xdg-desktop-portal-gtk')
+optdepends=('cura-5-plugin-octoprint: Cura plugin which enables printing directly to OctoPrint and monitoring the progress'
+ 'cura-5-plugin-octoprint-git: Cura plugin which enables printing directly to OctoPrint and monitoring the progress')
+conflicts=('cura-5-bin')
+provides=('cura')
+options=(!strip)
+DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
+source=(
+ "https://github.com/Ultimaker/Cura/releases/download/${pkgver}-beta/Ultimaker-Cura-${pkgver}-beta-linux.AppImage"
+ "${_shortname}.sh"
+ "cura.desktop.patch"
+)
+
+sha256sums=('77f13c5fb9c0582b283a122498f3a97339738b03b626d51a4fe13c2304502bda'
+ 'f7917a834849618f62147bf68e8cb1cb31157e724163325effd495ddd8be2494'
+ '22ee374746989baa4f87e79ecbc662b681ba9ca3fd93902408367461a2b4b571')
+
+prepare() {
+ cd "${srcdir}"
+ chmod +x ${srcdir}/Ultimaker-Cura-${pkgver}-beta-linux.AppImage
+ ${srcdir}/Ultimaker-Cura-${pkgver}-beta-linux.AppImage --appimage-extract 1>>/dev/null 2>>/dev/null
+ mv squashfs-root ${_shortname}
+ cd ${_shortname}
+ patch -Np0 < ${srcdir}/cura.desktop.patch
+
+}
+
+package() {
+ install -d "${pkgdir}/opt/"
+ cp -rf "${srcdir}/${_shortname}" "${pkgdir}/opt/"
+ install -d "${pkgdir}/usr/bin/"
+ install -Dm 755 "${srcdir}/cura5.sh" "${pkgdir}/usr/bin/${_shortname}"
+ install -Dm 644 "${srcdir}/cura5/cura-icon.png" "${pkgdir}/usr/share/pixmaps/cura5-icon.png"
+ install -Dm 644 "${srcdir}/cura5/cura.desktop" "${pkgdir}/usr/share/applications/cura5.desktop"
+}
diff --git a/cura.desktop.patch b/cura.desktop.patch
new file mode 100644
index 000000000000..ddc8c4373f0b
--- /dev/null
+++ b/cura.desktop.patch
@@ -0,0 +1,31 @@
+--- cura.desktop
++++ cura.desktop
+@@ -1,15 +1,21 @@
+ [Desktop Entry]
+-Name=Ultimaker Cura
+-Name[de]=Ultimaker Cura
++Name=Ultimaker Cura 5
++Name[cs]=Ultimaker Cura 5
++Name[de]=Ultimaker Cura 5
++Name[nl]=Ultimaker Cura 5
+ GenericName=3D Printing Software
++GenericName[cs]=3D-Tiskový Software
+ GenericName[de]=3D-Druck-Software
+ GenericName[nl]=3D-Print Software
+ Comment=Cura converts 3D models into paths for a 3D printer. It prepares your print for maximum accuracy, minimum printing time and good reliability with many extra features that make your print come out great.
+-Exec=Ultimaker-Cura %F
+-Icon=cura-icon
++Comment[cs]=Cura převádí 3D modely na cesty pro 3D tiskárnu. Připraví váš tisk na maximální přesnost, minimální dobu tisku a dobrou spolehlivost s mnoha dalšími funkcemi, díky nimž bude váš tisk skvělý.
++Comment[de]=Cura wandelt 3D-Modelle in Pfade für einen 3D-Drucker um. Es bereitet Ihren Druck für maximale Genauigkeit, minimale Druckzeit und guter Zuverlässigkeit mit vielen zusätzlichen Funktionen vor, damit Ihr Druck großartig wird.
++Comment[nl]=Cura converteert 3D-modellen naar paden voor een 3D printer. Het bereidt je print voor om zeer precies, snel en betrouwbaar te kunnen printen, met veel extra functionaliteit om je print er goed uit te laten komen.
++Exec=/usr/bin/cura5 %F
++Icon=cura5-icon
+ Terminal=false
+ Type=Application
+ MimeType=model/stl;application/vnd.ms-3mfdocument;application/prs.wavefront-obj;image/bmp;image/gif;image/jpeg;image/png;text/x-gcode;application/x-amf;application/x-ply;application/x-ctm;model/vnd.collada+xml;model/gltf-binary;model/gltf+json;model/vnd.collada+xml+zip;
+-Categories=Graphics;
+-Keywords=3D;Printing;
++Categories=Graphics;3DGraphics;Engineering;
++Keywords=3D;Printing;Slicer;
+ X-AppImage-Version=5.1.0
+
diff --git a/cura5.sh b/cura5.sh
new file mode 100755
index 000000000000..16c13f9c960e
--- /dev/null
+++ b/cura5.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+export QT_QPA_PLATAFORM=xdgdesktopportal
+export QT_QPA_PLATFORMTHEME=xdgdesktopportal
+cd /opt/cura5/
+LD_PRELOAD=/usr/lib/libstdc++.so.6 QT_QPA_PLATFORMTHEME=xdgdesktopportal QT_QPA_PLATAFORM=xdgdesktopportal ./Ultimaker-Cura $@
+