summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristian Gunstone2016-03-11 14:51:25 +0100
committerKristian Gunstone2016-03-11 14:52:31 +0100
commit7e7c6e31ba49a9251e0c98ccc6e007ab9cd9ca72 (patch)
tree956e3e1686678731286e00c448142c4f8af5f26b
downloadaur-7e7c6e31ba49a9251e0c98ccc6e007ab9cd9ca72.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD60
-rw-r--r--arch_aleph_patch.diff54
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..103ac82bc703
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = cura-aleph-bin
+ pkgdesc = A full 3D printing solution aimed at RepRaps and the Ultimaker. This is the Aleph Objects fork, specialized for the Lulzbot series of 3D printers.
+ pkgver = 18.03
+ pkgrel = 1
+ url = https://www.lulzbot.com/cura
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ depends = bash
+ depends = python2
+ depends = wxpython
+ depends = python2-opengl
+ depends = python2-pyserial
+ depends = python2-numpy
+ depends = python2-power-git
+ provides = cura
+ conflicts = cura
+ conflicts = cura-bin
+ conflicts = cura-git
+ conflicts = cura-old
+ conflicts = cura-not-so-old
+ source = http://download.lulzbot.com/Software/Cura/Packages/Cura_18/cura_18.03-8bed_amd64.deb
+ source = arch_aleph_patch.diff
+ sha1sums = 458528f3e1ea5033d0a2efdc10c9108184791a15
+ sha1sums = ba7a71da6f433e57e4cb67b9a295d4c249518b6e
+
+pkgname = cura-aleph-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..150bc34a2997
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Kristian Gunstone <kristian.gunstone.butnotthispart@pean.northis.org>
+# Contributor: Jan-Tarek Butt <tarek@ring0.de>
+# This PKGBUILD is based on the 'cura-old' PKGBUILD maintained by Jan-Tarek.
+# A specific version of CuraEngine is bundled with Aleph's Cura, and so it also
+# comes with this package.
+pkgname=cura-aleph-bin
+pkgver=18.03
+pkgrel=1
+pkgdesc="A full 3D printing solution aimed at RepRaps and the Ultimaker.
+This is the Aleph Objects fork, specialized for the Lulzbot series of 3D printers."
+arch=('i686' 'x86_64')
+url="https://www.lulzbot.com/cura"
+license=('AGPL3')
+depends=('bash'
+ 'python2'
+ 'wxpython'
+ 'python2-opengl'
+ 'python2-pyserial'
+ 'python2-numpy'
+ 'python2-power-git')
+provides=('cura')
+conflicts=('cura'
+ 'cura-bin'
+ 'cura-git'
+ 'cura-old'
+ 'cura-not-so-old')
+
+_aleph_ver_major=$(echo "$pkgver" | cut -d "." -f 1)
+_aleph_url_root="http://download.lulzbot.com/Software/Cura/Packages/Cura_${_aleph_ver_major}"
+
+if [ "$CARCH" == x86_64 ]; then
+ source+=(${_aleph_url_root}/cura_${pkgver}-8bed_amd64.deb)
+ sha1sums+=('458528f3e1ea5033d0a2efdc10c9108184791a15')
+elif [ "$CARCH" == i686 ]; then
+ source+=(${_aleph_url_root}/cura_${pkgver}-8bed_i386.deb)
+ sha1sums+=('fd6ed10d0b4fea59129be2596c044021ca94c648')
+fi
+
+source+=(arch_aleph_patch.diff)
+sha1sums+=('ba7a71da6f433e57e4cb67b9a295d4c249518b6e')
+
+prepare()
+{
+ # Unpack the tarball containing the 'usr/' directory,
+ # where all the essentials reside within the debian package
+ tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
+
+ # remove python-power since we have it in the deps:
+ rm -rv "${srcdir}"/usr/share/cura/power/
+ rm -rv "${srcdir}"/usr/share/cura/Cura/util/Power
+
+ # Apply the patchset, which mainly changes any ambiguous references
+ # to 'python' to 'python2' (as arch uses python3 by default)
+ patch -d "${srcdir}" -p1 < ../arch_aleph_patch.diff
+}
+
+package()
+{
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
+}
diff --git a/arch_aleph_patch.diff b/arch_aleph_patch.diff
new file mode 100644
index 000000000000..86ad7d4bb868
--- /dev/null
+++ b/arch_aleph_patch.diff
@@ -0,0 +1,54 @@
+diff -Naur old/usr/bin/cura new/usr/bin/cura
+--- old/usr/bin/cura 2015-08-11 23:04:07.000000000 +0200
++++ new/usr/bin/cura 2016-03-11 13:05:27.629762151 +0100
+@@ -1,2 +1,3 @@
+-#!/bin/sh
+-PYTHONPATH=$PYTHONPATH:/usr/share/cura/ /usr/bin/python /usr/share/cura/cura.py "$@"
++#!/bin/bash
++PYTHONPATH=$PYTHONPATH:/usr/share/cura/ /usr/bin/python2 /usr/share/cura/cura.py "$@"
++
+diff -Naur old/usr/share/applications/cura.desktop new/usr/share/applications/cura.desktop
+--- old/usr/share/applications/cura.desktop 2015-08-11 23:04:07.000000000 +0200
++++ new/usr/share/applications/cura.desktop 2016-03-11 13:03:55.201620044 +0100
+@@ -3,7 +3,7 @@
+ Name=Cura
+ Comment=Cura
+ Icon=/usr/share/cura/resources/images/c.png
+-Exec=/usr/bin/python /usr/share/cura/cura.py
++Exec=/usr/bin/python2 /usr/share/cura/cura.py
+ Path=/usr/share/cura/
+ StartupNotify=true
+ Terminal=false
+diff -Naur old/usr/share/cura/Cura/cura.py new/usr/share/cura/Cura/cura.py
+--- old/usr/share/cura/Cura/cura.py 2015-10-28 14:16:04.000000000 +0100
++++ new/usr/share/cura/Cura/cura.py 2016-03-11 13:06:25.808592243 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ """
+ This page is in the table of contents.
+ ==Overview==
+diff -Naur old/usr/share/cura/Cura/util/pymclevel/mce.py new/usr/share/cura/Cura/util/pymclevel/mce.py
+--- old/usr/share/cura/Cura/util/pymclevel/mce.py 2015-08-11 23:04:07.000000000 +0200
++++ new/usr/share/cura/Cura/util/pymclevel/mce.py 2016-03-11 13:08:27.256148959 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ import mclevelbase
+ import mclevel
+ import infiniteworld
+diff -Naur old/usr/share/cura/cura.py new/usr/share/cura/cura.py
+--- old/usr/share/cura/cura.py 2015-12-11 22:15:26.000000000 +0100
++++ new/usr/share/cura/cura.py 2016-03-11 13:03:55.204953309 +0100
+@@ -1,8 +1,9 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ import os, sys
+
+-sys.path.insert(1, os.path.dirname(__file__))
++sys.path.insert(1, "/usr/share/cura")
++os.chdir("/usr/share/cura")
+
+ try:
+ import OpenGL