summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGennadiy Mykhailiuta2022-07-14 21:19:25 +0000
committerGennadiy Mykhailiuta2022-07-14 21:19:25 +0000
commitb339ddfca54a1618ef1ce5acf45627048389f2b2 (patch)
tree66ab022e6aa7beb4a45576864f9642208739fc61
parent666030453a98a3af032b7d7e701e5c86da1b0756 (diff)
downloadaur-b339ddfca54a1618ef1ce5acf45627048389f2b2.tar.gz
Update cura.sh
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--cura.sh11
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a20c07fb72c8..edcc13be4d96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = cura-appimage-bin
pkgdesc = Ultimakers 3D printer / slicing GUI built on top of the Uranium framework
pkgver = 5.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://ultimaker.com/software/ultimaker-cura
arch = x86_64
license = LGPL3
depends = fuse2
+ depends = xdg-desktop-portal
provides = cura
conflicts = cura
conflicts = cura-appimage-git
- conflicts = cura-appimage-bin
noextract = ${_pkgname}-${pkgver}.AppImage
options = !strip
source = Ultimaker-Cura-5.0.0.AppImage::https://github.com/Ultimaker/Cura/releases/download/5.0.0/Ultimaker-Cura-5.0.0-linux.AppImage
source = cura.sh
source = cura.desktop.patch
sha256sums = ec00f8e42a46fd24cd71e098fa713a08be4e2bcc6df17d5d02938bc6ea315754
- sha256sums = 6430e6359ff98b7c6a209181c389cfc606d1e84628793a4eb772c5e2f0d0a23f
+ sha256sums = 4963059128568520093840e43eec90691be81739864f74b36529512a852e5239
sha256sums = 6c1b54af7077ca101cca099f40d9627d6d69e9b11a5a6ae0667e118d764dc903
pkgname = cura-appimage-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5f58e5cfcd15..b9046c188e9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@ pkgname=cura-appimage-bin
_pkgname=Ultimaker-Cura
_shortname=cura
pkgver=5.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Ultimakers 3D printer / slicing GUI built on top of the Uranium framework'
arch=('x86_64')
url="https://ultimaker.com/software/ultimaker-cura"
license=('LGPL3')
-depends=('fuse2')
+depends=('fuse2' 'xdg-desktop-portal')
provides=('cura')
-conflicts=('cura' 'cura-appimage-git' 'cura-appimage-bin')
+conflicts=('cura' 'cura-appimage-git')
options=(!strip)
DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
noextract=('${_pkgname}-${pkgver}.AppImage')
@@ -25,7 +25,7 @@ source=(
sha256sums=(
"ec00f8e42a46fd24cd71e098fa713a08be4e2bcc6df17d5d02938bc6ea315754"
- "6430e6359ff98b7c6a209181c389cfc606d1e84628793a4eb772c5e2f0d0a23f"
+ "4963059128568520093840e43eec90691be81739864f74b36529512a852e5239"
"6c1b54af7077ca101cca099f40d9627d6d69e9b11a5a6ae0667e118d764dc903"
)
diff --git a/cura.sh b/cura.sh
index 21f847908dcb..66dd2fed9eac 100644
--- a/cura.sh
+++ b/cura.sh
@@ -3,11 +3,14 @@
# For easier maintainability
CURA_VERSION="VERSION_PLACEHOLDER"
CURA_BIN_PATH="/opt/Ultimaker-Cura/Ultimaker-Cura-$CURA_VERSION.AppImage"
+FIXUPS="LD_PRELOAD=/usr/lib/libstdc++.so.6"
# Get full path to avoid Error Message in cura
-[[ -n $(dirname "$1") ]] && filePath="$(realpath "$1")" || filePath="$1"
+[ -n $(dirname "$1") ] && filePath="$(realpath "$1")" || filePath="$1"
# Start cura-appimage without Parameter if not given. ( Avoiding cura Error Message "No file found" )
-[[ -z $filePath ]] && $CURA_BIN_PATH || $CURA_BIN_PATH "$filePath"
-
-exit
+if [ -z $filePath ]; then
+ env ${FIXUPS} $CURA_BIN_PATH
+else
+ env ${FIXUPS} $CURA_BIN_PATH "$filePath"
+fi