summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-01-24 13:13:18 -0500
committerAdam Goldsmith2017-01-24 13:13:18 -0500
commit01593ce1eb5b4a6596e28d2f77693be58de7aa18 (patch)
tree0371dd6377599f4800f075c02cf419dcf1d2508e
parent394a6503179dc88b929f927d433dc006cb889cc0 (diff)
downloadaur-01593ce1eb5b4a6596e28d2f77693be58de7aa18.tar.gz
Use git sources, remove translations
translations removed because they are redundant for the cura-git and uranium-git packages
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd08ae7718ad..02b0d1d39248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Sat Dec 3 16:02:17 UTC 2016
-pkgbase = cura-binary-data
- pkgdesc = Binary data (firmwares and such) for cura
- pkgver = 2.3.1
- pkgrel = 2
- url = https://github.com/Ultimaker/cura-binary-data
+# Tue Jan 24 18:12:29 UTC 2017
+pkgbase = cura-binary-data-git
+ pkgdesc = Binary data (firmwares) for cura
+ pkgver = 2.3.0.17.geb270fa
+ pkgrel = 1
+ url = https://github.com/Ultimaker/cura-binary-data-git
arch = any
license = AGPLv3
- source = https://github.com/Ultimaker/cura-binary-data/archive/2.3.1.tar.gz
- sha1sums = 69998bab0efd410b481f8bb6ba6c8f650f2e87e8
+ source = git+https://github.com/Ultimaker/cura-binary-data.git
+ sha1sums = SKIP
-pkgname = cura-binary-data
+pkgname = cura-binary-data-git
diff --git a/PKGBUILD b/PKGBUILD
index e6a599b1e099..4b54270f49fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+# Based on cura-binary-data by: Grey Christoforo <my first name [at] my last name [dot] net>
-pkgname=cura-binary-data
-pkgver=2.3.1
-pkgrel=2
-pkgdesc="Binary data (firmwares and such) for cura"
+pkgname=cura-binary-data-git
+_pkgname=cura-binary-data
+pkgver=2.3.0.17.geb270fa
+pkgrel=1
+pkgdesc="Binary data (firmwares) for cura"
depends=()
url="https://github.com/Ultimaker/${pkgname}"
license=('AGPLv3')
arch=('any')
#options=(!strip docs libtool emptydirs !zipman staticlibs !upx)
-source=(https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz)
-sha1sums=('69998bab0efd410b481f8bb6ba6c8f650f2e87e8')
+source=('git+https://github.com/Ultimaker/cura-binary-data.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags | sed 's/-/./g'
+}
package(){
- mkdir -p "${pkgdir}/usr/share"
- cp -r "${srcdir}/${pkgname}-${pkgver}/cura/" "${pkgdir}/usr/share/."
- #cp -r "${srcdir}/${pkgname}-${pkgver}/uranium/" "${pkgdir}/usr/share/."
+ mkdir -p "${pkgdir}/usr/share/cura/resources/"
+ cp -r "${srcdir}/${_pkgname}/cura/resources/firmware" "${pkgdir}/usr/share/cura/resources/"
}