summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-12-03 15:57:37 +0000
committerGrey Christoforo2016-12-03 15:57:37 +0000
commit46cf539ccae35a1943b2315ba59ba882ae0f659d (patch)
tree4f01685ac202cada39d5282df0da9df4eda2746b
downloadaur-46cf539ccae35a1943b2315ba59ba882ae0f659d.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb2f26f86f6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Dec 3 15:55:35 UTC 2016
+pkgbase = cura-binary-data
+ pkgdesc = Binary data (firmwares and such) for cura
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://github.com/Ultimaker/cura-binary-data
+ arch = any
+ license = AGPLv3
+ options = !strip
+ options = docs
+ options = libtool
+ options = emptydirs
+ options = !zipman
+ options = staticlibs
+ options = !upx
+ source = https://github.com/Ultimaker/cura-binary-data/archive/2.3.1.tar.gz
+ sha1sums = 69998bab0efd410b481f8bb6ba6c8f650f2e87e8
+
+pkgname = cura-binary-data
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65df10365540
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
+
+pkgname=cura-binary-data
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Binary data (firmwares and such) for cura"
+depends=()
+url="https://github.com/Ultimaker/${pkgname}"
+license=('AGPLv3')
+arch=('any')
+#options=(!strip docs libtool emptydirs !zipman staticlibs !upx)
+source=(https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz)
+sha1sums=('69998bab0efd410b481f8bb6ba6c8f650f2e87e8')
+
+package(){
+ mkdir -p "${pkgdir}/usr/share"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/cura/" "${pkgdir}/usr/share/."
+ cp -r "${srcdir}/${pkgname}-${pkgver}/uranium/" "${pkgdir}/usr/share/."
+}
+
+