summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenha2016-10-11 12:23:03 +0300
committerRenha2016-10-11 12:23:03 +0300
commit08f4554670ff99cc83ba019bf0d4122995d31e09 (patch)
tree3cff18233e4bfa3c920066fd398f24160daacc5b
parent958caf734846a0dafd68d36d08eb86a9e06ea4e2 (diff)
downloadaur-08f4554670ff99cc83ba019bf0d4122995d31e09.tar.gz
Added all resources from Cura to be able to deal with all needed printers.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb039166a8e4..e2f53183ba17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cura-engine-noarcus-git
- pkgdesc = A C++ console application for 3D printing GCode generation. It's called by Repetier Host and/or other applications. No libArcus or Protobuf needed for that version, and it could be only used as command-line tool.
+ pkgdesc = A C++ console application for 3D printing GCode generation. No libArcus or Protobuf needed for that version, and it could be only used as command-line tool.
pkgver = 3b8ad5e
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Ultimaker/CuraEngine.git
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1be63ae7a148..c8d7d6de900d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=cura-engine-noarcus-git
pkgver=3b8ad5e
-pkgrel=3
-pkgdesc="A C++ console application for 3D printing GCode generation. It's called by Repetier Host and/or other applications. No libArcus or Protobuf needed for that version, and it could be only used as command-line tool."
+pkgrel=4
+pkgdesc="A C++ console application for 3D printing GCode generation. No libArcus or Protobuf needed for that version, and it could be only used as command-line tool."
arch=(i686 x86_64 arm)
url="https://github.com/Ultimaker/CuraEngine.git"
license=(GPL)
@@ -39,11 +39,11 @@ pkgver() {
build4git() {
cd "${srcdir}/${pkgname}"
- # add version
- sed -i -e "s|add_definitions[ \t]*([ \t]*-DVERSION=.*||" CMakeLists.txt
- echo "add_definitions( -DVERSION=\"git-$(pkgver)\" )" >> CMakeLists.txt
- # patch default folder
- sed -i -e "s|loadJSON[ \t]*([ \t]*\"fdmprinter.json|loadJSON(\"/usr/share/${pkgname}/fdmprinter.json|" src/main.cpp
+ # add version // doesn't work with actual version
+ #sed -i -e "s|add_definitions[ \t]*([ \t]*-DVERSION=.*||" CMakeLists.txt
+ #echo "add_definitions( -DVERSION=\"git-$(pkgver)\" )" >> CMakeLists.txt
+ # patch default folder // cancelled, doesn't work with actual version
+ #sed -i -e "s|loadJSON[ \t]*([ \t]*\"fdmprinter.json|loadJSON(\"/usr/share/${pkgname}/fdmprinter.json|" src/main.cpp
mkdir -p build
cd build
@@ -65,7 +65,8 @@ package4git() {
mkdir -p ${pkgdir}/usr/bin/
cp build/CuraEngine ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/share/${pkgname}/
- cp "${srcdir}/cura-git/resources/definitions/fdmprinter.def.json" ${pkgdir}/usr/share/${pkgname}/
+ cp -r resources ${pkgdir}/usr/share/${pkgname}/
+ cp -r "${srcdir}/cura-git/resources/*" ${pkgdir}/usr/share/${pkgname}/resources
}
package4release() {