summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-01-29 17:40:08 -0500
committerAdam Goldsmith2017-01-29 17:45:03 -0500
commitc33c2a4d7b7e1a473ace6dcf897dfcc858b5fd4a (patch)
tree3f5953ea46b9cb976a2b3c6f7ac41bb0c12794ab
downloadaur-c33c2a4d7b7e1a473ace6dcf897dfcc858b5fd4a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11dbae081f87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jan 29 22:43:24 UTC 2017
+pkgbase = cura-fdm-materials-git
+ pkgdesc = A full software solution for 3D printing aimed at RepRaps and the Ultimaker.
+ pkgver = cura.2.3.0.7.g96f68f3
+ pkgrel = 1
+ url = https://github.com/Ultimaker/fdm_materials
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ provides = cura-fdm-materials
+ conflicts = cura-fdm-materials
+ source = git+https://github.com/Ultimaker/fdm_materials
+ md5sums = SKIP
+
+pkgname = cura-fdm-materials-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dacba1adc64b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+fdm_materials/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c053c18cef7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=cura-fdm-materials-git
+pkgver=cura.2.3.0.7.g96f68f3
+pkgrel=1
+pkgdesc="A full software solution for 3D printing aimed at RepRaps and the Ultimaker."
+arch=('any')
+license=('GPL3')
+url="https://github.com/Ultimaker/fdm_materials"
+provides=('cura-fdm-materials')
+conflicts=('cura-fdm-materials')
+depends=()
+makedepends=('git' 'cmake')
+source=('git+https://github.com/Ultimaker/fdm_materials')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fdm_materials
+ git describe --tags | sed 's/-/./g'
+}
+
+build() {
+ mkdir -p fdm_materials/build
+ cd fdm_materials/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/fdm_materials/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: