summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-06-24 21:17:07 -0400
committerAdam Goldsmith2015-06-24 21:17:07 -0400
commita75cac4bc86f5b5999e37a2be724421622ecdd58 (patch)
tree8d838a4c742ecd4491f195c9e28102df672e59a8
parent41661b035be41e6c6d05ff3bd736701e3b482d85 (diff)
downloadaur-a75cac4bc86f5b5999e37a2be724421622ecdd58.tar.gz
switch to master branch on all but CuraEngine, add patch for relative path in recent versions
-rw-r--r--Cura-CMakeLists.patch11
-rw-r--r--PKGBUILD14
2 files changed, 21 insertions, 4 deletions
diff --git a/Cura-CMakeLists.patch b/Cura-CMakeLists.patch
new file mode 100644
index 000000000000..c5ad2afebd1a
--- /dev/null
+++ b/Cura-CMakeLists.patch
@@ -0,0 +1,11 @@
+--- Cura/CMakeLists.txt 2015-06-22 09:16:37.262735692 -0400
++++ Cura/CmakeLists.txt.new 2015-06-22 09:25:31.044757891 -0400
+@@ -2,7 +2,7 @@
+ project(cura)
+ cmake_minimum_required(VERSION 2.8.12)
+
+-set(URANIUM_SCRIPTS_DIR "${CMAKE_SOURCE_DIR}/../uranium/scripts" CACHE DIRECTORY "The location of the scripts directory of the Uranium repository")
++set(URANIUM_SCRIPTS_DIR "${CMAKE_SOURCE_DIR}/../Uranium/scripts" CACHE DIRECTORY "The location of the scripts directory of the Uranium repository")
+
+ if(NOT ${URANIUM_SCRIPTS_DIR} STREQUAL "")
+ # Extract Strings
diff --git a/PKGBUILD b/PKGBUILD
index 573047f0a304..5cc789f05358 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=cura-git
-pkgver=15.05.90.44.g98befd6
+pkgver=15.05.90.129.ga429e36
pkgrel=1
pkgdesc="A full software solution for 3D printing aimed at RepRaps and the Ultimaker."
arch=('i686' 'x86_64')
@@ -12,9 +12,10 @@ conflicts=('cura')
depends=('python' 'python-pyqt5' 'python-opengl' 'python-pyserial' 'python-numpy' 'python-power-git' 'python-protobuf3' 'libarcus-git' 'qt5-quickcontrols')
makedepends=('git' 'cmake')
source=('git+https://github.com/Ultimaker/Cura.git'
- 'git+https://github.com/Ultimaker/CuraEngine.git'
- 'git+https://github.com/Ultimaker/Uranium.git')
-md5sums=('SKIP' 'SKIP' 'SKIP')
+ 'git+https://github.com/Ultimaker/CuraEngine.git#branch=15.06'
+ 'git+https://github.com/Ultimaker/Uranium.git'
+ 'Cura-CMakeLists.patch')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'd6f730df5704d52b98c08676fd513c6b')
_gitname="Cura"
_gitbranch="master"
@@ -24,6 +25,11 @@ pkgver() {
git describe --tags | sed 's/-/./g'
}
+prepare() {
+ cd "$srcdir"
+ patch -p0 <Cura-CMakeLists.patch
+}
+
build() {
mkdir -p CuraEngine/build
cd CuraEngine/build