summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin McCormack2018-07-24 02:00:31 -0400
committerKevin McCormack2018-07-24 02:00:31 -0400
commit107ea152c20ec8c3e12f6b0bc8d95d3ef1483f7c (patch)
tree975566d184443d81cc6fdc103a8e04e9a2e27d3e
downloadaur-107ea152c20ec8c3e12f6b0bc8d95d3ef1483f7c.tar.gz
First commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc5269edb9b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cura-lulzbot
+ pkgdesc = Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.
+ pkgver = 3.2.23
+ pkgrel = 1
+ url = https://www.lulzbot.com/cura
+ arch = x86_64
+ license = AGPLv3
+ depends = gcc6-fortran
+ source = http://download.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura-lulzbot_3.2.23_amd64.deb
+ md5sums = f7d72032890f5479b7cc7d650ca13600
+
+pkgname = cura-lulzbot
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ef4ac456640
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kevin McCormack <harlemsquirrel@gmail.com>
+pkgname=cura-lulzbot
+pkgver=3.2.23
+pkgrel=1
+pkgdesc='Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.'
+arch=('x86_64')
+url='https://www.lulzbot.com/cura'
+license=('AGPLv3')
+source=("http://download.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura-lulzbot_${pkgver}_amd64.deb")
+md5sums=('f7d72032890f5479b7cc7d650ca13600')
+depends=('gcc6-fortran')
+
+prepare() {
+ # Unpack the tarball containing the 'usr/' directory,
+ # where all the essentials reside within the debian package
+ tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
+
+ sed -i 's;LD_LIBRARY_PATH=;LD_LIBRARY_PATH=/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.1:;' "${srcdir}/usr/bin/cura-lulzbot"
+}
+
+package() {
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
+}
+
+## Update .SRCINFO
+# makepkg --printsrcinfo | tee .SRCINFO