summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Tarek Butt2015-08-28 11:54:01 +0200
committerJan-Tarek Butt2015-08-28 11:54:01 +0200
commit894504451d6be2219995dee4d36b9d33b0109756 (patch)
tree2eefb71b76773ef2c42bc5c3bb4a53cecd737627
downloadaur-894504451d6be2219995dee4d36b9d33b0109756.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
-rw-r--r--cura.install34
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6c7f08f789c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cura-old
+ pkgdesc = A full software solution for 3D printing aimed at RepRaps and the Ultimaker. (the old one)
+ pkgver = 15.04.2
+ pkgrel = 1
+ url = http://blog.ultimaker.com/cura-user-manual/
+ install = cura.install
+ arch = i686
+ arch = x86_64
+ license = AGPLv3
+ depends = python2
+ depends = wxpython
+ depends = python2-opengl
+ depends = python2-pyserial
+ depends = python2-numpy
+ depends = python2-power-git
+ provides = cura
+
+pkgname = cura
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e211be84155
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jan-Tarek Butt <tarek@ring0.de>
+pkgbase=cura-old
+pkgname=cura
+pkgver=15.04.2
+pkgrel=1
+pkgdesc="A full software solution for 3D printing aimed at RepRaps and the Ultimaker. (the old one)"
+depends=('python2' 'wxpython' 'python2-opengl' 'python2-pyserial' 'python2-numpy' 'python2-power-git')
+provides=('cura')
+url="http://blog.ultimaker.com/cura-user-manual/"
+license=('AGPLv3')
+arch=('i686' 'x86_64')
+if [ "$CARCH" == x86_64 ]; then
+ source+=(http://software.ultimaker.com/current/cura_${pkgver}-debian_amd64.deb)
+ sha1sums+=('8b75c7dd29e68718d1abc7467083327567466131')
+elif [ "$CARCH" == i686 ]; then
+ source+=(http://software.ultimaker.com/current/cura_${pkgver}-debian_i386.deb)
+ sha1sums+=('098b54e118cc7d238aa7cde3b1ad065dff1dee31')
+fi
+
+install=cura.install
+
+build()
+{
+ cd "${srcdir}"
+
+ # unpack
+ tar --xz -xf data.tar.xz
+}
+
+package()
+{
+ # remove python-power since we have it in the deps:
+ rm -rf "${srcdir}"/usr/share/cura/power/
+
+ # change python to python2 everywhere:
+ sed -i 's|\/usr\/bin\/python|\/usr\/bin\/python2|' "${srcdir}"/usr/share/applications/cura.desktop "${srcdir}"/usr/share/cura/cura.py "${srcdir}"/usr/bin/cura
+
+ # add a new line (pedantic):
+ echo >> "${srcdir}/usr/bin/cura"
+
+ # add the path since we need to call slicer exactly from /usr/share/cura
+ sed -i '6 i os.chdir("/usr/share/cura")' "${srcdir}"/usr/share/cura/cura.py
+ sed -i 's|os.path.dirname(__file__)|"/usr/share/cura"|' "${srcdir}"/usr/share/cura/cura.py
+
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
+}
diff --git a/cura.install b/cura.install
new file mode 100644
index 000000000000..951bb1f57641
--- /dev/null
+++ b/cura.install
@@ -0,0 +1,34 @@
+# Some colored makepkg-like functions
+msg_blue()
+{
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note_blue()
+{
+ printf "${BLUE}==>${ALL_OFF}${BOLD} NOTE${1}:${ALL_OFF} ${2}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+GREEN="${BOLD}$(tput setaf 2)"
+
+post_install()
+{
+ echo
+ msg_blue "Make sure you have permission to write to your 3D printer device."
+ msg_blue "If not, add your username to uucp group in /etc/group and log out."
+ echo
+ msg_blue "If you are unable to connect to your printer, change baudrate"
+ msg_blue "in File -> Preferences to 115200 (250000 is known to not work quite often)"
+ msg_blue "and restart Cura afterwards. If you see garbage in the ultimaker console"
+ msg_blue "when you connect to the printer try lowering the baudrate even more."
+ msg_blue "Don't forget to restart Cura after each change."
+ echo
+}
+
+post_upgrade()
+{
+ post_install
+}