summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-01-24 13:37:17 -0500
committerAdam Goldsmith2017-01-24 13:37:17 -0500
commit58f9a7f6adfdc1f943abcf8a1f4eacec204b3ae3 (patch)
tree75a7ebb8f9cad7b1be56098cc4a387998a4cca2f
downloadaur-58f9a7f6adfdc1f943abcf8a1f4eacec204b3ae3.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e99d53dfd13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jan 24 18:35:47 UTC 2017
+pkgbase = cura-plugin-octoprint-git
+ pkgdesc = Cura plugin which enables printing directly to OctoPrint and monitoring the progress
+ pkgver = r74.0d400df
+ pkgrel = 1
+ url = https://github.com/fieldofview/OctoPrintPlugin
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = cura
+ depends = python-zeroconf
+ source = cura-plugin-octoprint::git+https://github.com/fieldofview/OctoPrintPlugin.git
+ md5sums = SKIP
+
+pkgname = cura-plugin-octoprint-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..715c28d459c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/cura-plugin-octoprint/
+*.pkg.tar*
+/src/
+/pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a18c5f2980f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=cura-plugin-octoprint-git
+_pkgname=cura-plugin-octoprint
+pkgver=r74.0d400df
+pkgrel=1
+pkgdesc="Cura plugin which enables printing directly to OctoPrint and monitoring the progress"
+arch=('any')
+license=('GPL3')
+url="https://github.com/fieldofview/OctoPrintPlugin"
+depends=('python' 'cura' 'python-zeroconf')
+makedepends=('git')
+source=("$_pkgname::git+https://github.com/fieldofview/OctoPrintPlugin.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p "$_pkgname"/build
+ cd "$_pkgname"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: