summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristophe Drevet-Droguet2017-09-10 19:02:26 +0200
committerChristophe Drevet-Droguet2017-09-10 20:36:18 +0200
commit85b19cce13a4e5b35a596b3d195dba858b458a4b (patch)
tree6d3158c8ff3c3aa44664d708ecf3e6c1597979e6
downloadaur-85b19cce13a4e5b35a596b3d195dba858b458a4b.tar.gz
first try at packaging Fabtotum Cura profile
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70e18f6dff90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cura-resources-fabtotum-git
+ pkgdesc = FabTotum resources for Cura 2.x
+ pkgver = r27.c4b13cd
+ pkgrel = 1
+ url = https://github.com/FABtotum/FAB_Configs
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = cura
+ source = git+https://github.com/FABtotum/FAB_Configs.git
+ md5sums = SKIP
+
+pkgname = cura-resources-fabtotum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7e7b75b1931
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: dr4Ke <dr4ke at dr4ke dot net>
+pkgname=cura-resources-fabtotum-git
+pkgver=r27.c4b13cd
+pkgrel=1
+pkgdesc="FabTotum resources for Cura 2.x"
+arch=('any')
+url="https://github.com/FABtotum/FAB_Configs"
+license=('unknown')
+depends=('cura')
+makedepends=('git')
+source=('git+https://github.com/FABtotum/FAB_Configs.git')
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/FAB_Configs"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/FAB_Configs"
+ cd "Cura2.x_configs_FABtotum/Cura 2.5/resources"
+ mkdir -p "${pkgdir}/usr/share/cura/resources/"
+ cp -rp . "${pkgdir}/usr/share/cura/resources/"
+}