aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin McCormack2018-01-17 22:52:58 -0500
committerKevin McCormack2018-01-17 22:52:58 -0500
commitc2b3c54970fd9c79451a978c82bb7107f43d7f61 (patch)
tree6037981f2ce8f64dd5e808b11ffa17433a555115
parent60a4b401c60d333d57ce4087eb8e9a9754cc316b (diff)
downloadaur-c2b3c54970fd9c79451a978c82bb7107f43d7f61.tar.gz
Update pkgbuild
Change version to 2.6.66 Set up libgfortran symlink
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 829dfd81bdb4..824c1d5417ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: Kevin McCormack <harlemsquirrel@gmail.com>
pkgname=cura2-lulzbot
-pkgver=2.6.52
+pkgver=2.6.66
pkgrel=1
pkgdesc='This is the development version of Cura 2 for LulzBot 3D Printers by Aleph Objects, Inc.'
arch=('x86_64')
url='https://code.alephobjects.com'
license=('AGPLv3')
source=("http://download.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura-lulzbot_${pkgver}_amd64.deb")
-md5sums=('2aa34eb60d5a4d536c4fa16ee7100347')
+md5sums=('6db28b535fed7d7efe7ae01da55ff650')
+depends=('gcc6-fortran')
prepare() {
# Unpack the tarball containing the 'usr/' directory,
# where all the essentials reside within the debian package
tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
+
+ if [ ! -e /usr/lib/libgfortran.so.3 ]; then
+ # Set up link for libgfortran that cura-lulzbot will look for
+ printf "We need sudo access to set up symlink for libgfortran \n"
+ sudo ln -sf /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.1/libgfortran.so /usr/lib/libgfortran.so.3
+ fi
}
package() {