aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin McCormack2017-08-11 01:45:06 -0400
committerKevin McCormack2017-08-13 17:14:03 -0400
commitc32cae31ae176aac859301fdf599371efb38c9d8 (patch)
treecb46010582a783478cecec95084a08065fd60863
downloadaur-c32cae31ae176aac859301fdf599371efb38c9d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56dfcbdbabf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = cura2-lulzbot
+ pkgdesc = This is the development version of Cura 2 for LulzBot 3D Printers by Aleph Objects, Inc.
+ pkgver = 2.6.22
+ pkgrel = 1
+ url = https://code.alephobjects.com
+ arch = x86_64
+ license = AGPLv3
+ source = http://devel.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura2_2.6.22_amd64.deb
+ md5sums = 30612c9f76097dc968c725c7e2ddea1d
+
+pkgname = cura2-lulzbot
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d664778e0a95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.deb
+*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9066c9a187e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Kevin McCormack <harlemsquirrel@gmail.com>
+pkgname=cura2-lulzbot
+pkgver=2.6.22
+pkgrel=1
+pkgdesc='This is the development version of Cura 2 for LulzBot 3D Printers by Aleph Objects, Inc.'
+arch=('x86_64')
+url='https://code.alephobjects.com'
+license=('AGPLv3')
+source=("http://devel.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura2_${pkgver}_amd64.deb")
+md5sums=('30612c9f76097dc968c725c7e2ddea1d')
+
+prepare() {
+ # Unpack the tarball containing the 'usr/' directory,
+ # where all the essentials reside within the debian package
+ tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
+}
+
+package() {
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
+}