summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthewRalston2018-11-15 17:08:29 -0500
committerMatthewRalston2018-11-15 17:14:45 -0500
commitddaa14d738335bc2e6271c5144c92b5b5b0e3c1d (patch)
tree5edc81934948129ddaa908e5b6aae2b5d40a4723
downloadaur-ddaa14d738335bc2e6271c5144c92b5b5b0e3c1d.tar.gz
First realease, points to curam on github.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cef44cfe8749
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = curam-git
+ pkgdesc = Provides maintenace functions for Arch Linux.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/MatthewRalston/curam
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = perl
+ depends = package-query
+ depends = rsync
+ depends = aws-cli
+ provides = curam
+ backup = etc/curam/curam.conf
+ backup = etc/curam/home_excludes.conf
+ backup = etc/curam/media_excludes.conf
+ backup = etc/curam/os_excludes.conf
+ backup = etc/curam/symlinks_check.conf
+
+pkgname = curam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..064f2e4e49da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Matthew Ralston <mrals89@gmail.com>
+pkgname="curam-git"
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Provides maintenace functions for Arch Linux."
+arch=('any')
+url="https://github.com/MatthewRalston/curam"
+license=('GPL')
+groups=()
+depends=('perl' 'package-query' 'rsync' 'aws-cli')
+makedepends=('git')
+optdepends=()
+provides=('curam')
+backup=('etc/curam/curam.conf' 'etc/curam/home_excludes.conf' 'etc/curam/media_excludes.conf' 'etc/curam/os_excludes.conf' 'etc/curam/symlinks_check.conf')
+options=()
+source=("https://github.com/MatthewRalston/curam/archive/v0.0.1.tar.gz")
+#autofill using updpkgsums
+
+build() {
+ cd "$srcdir"
+ make PREFIX=/usr docs
+}
+
+package() {
+ cd "$srcdir"
+
+ make DESTDIR="$pkgdir/" install
+}