summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2021-02-20 00:48:11 +0500
committerDmitry Kharitonov2021-02-20 00:48:11 +0500
commita22d6c16fa4fa24984d606503f2582617d701be7 (patch)
treeadbaf495fed5189d481dda8692b5ba9f22870d9b
parent4e26c48dcc72bdbb7658797f6a5ed71d700cfeac (diff)
downloadaur-a22d6c16fa4fa24984d606503f2582617d701be7.tar.gz
Added a patch for new boost
-rw-r--r--.SRCINFO4
-rw-r--r--62.patch69
-rw-r--r--PKGBUILD11
3 files changed, 81 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9e0390e1973..ea9640739fd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = curecoin-qt-git
pkgdesc = GUI client (wallet) for CureCoin cryptocurrency
pkgver = v2.0.0.2.r24.g3ef6a62
- pkgrel = 1
+ pkgrel = 2
url = https://curecoin.net/
arch = x86_64
arch = i686
@@ -17,8 +17,10 @@ pkgbase = curecoin-qt-git
provides = curecoin-qt
conflicts = curecoin-qt
source = git+https://github.com/cygnusxi/CurecoinSource.git
+ source = 62.patch
source = curecoin.desktop
sha256sums = SKIP
+ sha256sums = e4b91a65d1f1afe7c165cbc4f090bfe4dc914a36915e9ef5f5d6ba0a981db0af
sha256sums = 47e4c7305240dd16361d922bf6bc3a86ee53d7e0bc43bdf12c341ea0b7968387
pkgname = curecoin-qt-git
diff --git a/62.patch b/62.patch
new file mode 100644
index 000000000000..3e321a790f12
--- /dev/null
+++ b/62.patch
@@ -0,0 +1,69 @@
+From 76528b543675f817a97a64634c648ae831e94713 Mon Sep 17 00:00:00 2001
+From: Jan van der Lugt <janlugt@gmail.com>
+Date: Sun, 3 Jan 2021 22:54:42 -0800
+Subject: [PATCH] Use fully qualified boost::placeholders identifiers.
+
+---
+ src/qt/clientmodel.cpp | 12 ++++++++----
+ src/qt/walletmodel.cpp | 16 ++++++++++------
+ 2 files changed, 18 insertions(+), 10 deletions(-)
+
+diff --git a/src/qt/clientmodel.cpp b/src/qt/clientmodel.cpp
+index df18b09..b3f5a17 100644
+--- a/src/qt/clientmodel.cpp
++++ b/src/qt/clientmodel.cpp
+@@ -190,14 +190,18 @@ void ClientModel::subscribeToCoreSignals()
+ {
+ // Connect signals to client
+ uiInterface.NotifyBlocksChanged.connect(boost::bind(NotifyBlocksChanged, this));
+- uiInterface.NotifyNumConnectionsChanged.connect(boost::bind(NotifyNumConnectionsChanged, this, _1));
+- uiInterface.NotifyAlertChanged.connect(boost::bind(NotifyAlertChanged, this, _1, _2));
++ uiInterface.NotifyNumConnectionsChanged.connect(boost::bind(NotifyNumConnectionsChanged, this,
++ boost::placeholders::_1));
++ uiInterface.NotifyAlertChanged.connect(boost::bind(NotifyAlertChanged, this, boost::placeholders::_1,
++ boost::placeholders::_2));
+ }
+
+ void ClientModel::unsubscribeFromCoreSignals()
+ {
+ // Disconnect signals from client
+ uiInterface.NotifyBlocksChanged.disconnect(boost::bind(NotifyBlocksChanged, this));
+- uiInterface.NotifyNumConnectionsChanged.disconnect(boost::bind(NotifyNumConnectionsChanged, this, _1));
+- uiInterface.NotifyAlertChanged.disconnect(boost::bind(NotifyAlertChanged, this, _1, _2));
++ uiInterface.NotifyNumConnectionsChanged.disconnect(boost::bind(NotifyNumConnectionsChanged, this,
++ boost::placeholders::_1));
++ uiInterface.NotifyAlertChanged.disconnect(boost::bind(NotifyAlertChanged, this, boost::placeholders::_1,
++ boost::placeholders::_2));
+ }
+diff --git a/src/qt/walletmodel.cpp b/src/qt/walletmodel.cpp
+index 75225f3..04ab2f7 100644
+--- a/src/qt/walletmodel.cpp
++++ b/src/qt/walletmodel.cpp
+@@ -335,17 +335,21 @@ static void NotifyTransactionChanged(WalletModel *walletmodel, CWallet *wallet,
+ void WalletModel::subscribeToCoreSignals()
+ {
+ // Connect signals to wallet
+- wallet->NotifyStatusChanged.connect(boost::bind(&NotifyKeyStoreStatusChanged, this, _1));
+- wallet->NotifyAddressBookChanged.connect(boost::bind(NotifyAddressBookChanged, this, _1, _2, _3, _4, _5));
+- wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
++ wallet->NotifyStatusChanged.connect(boost::bind(&NotifyKeyStoreStatusChanged, this, boost::placeholders::_1));
++ wallet->NotifyAddressBookChanged.connect(boost::bind(NotifyAddressBookChanged, this, boost::placeholders::_1, boost::placeholders::_2,
++ boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5));
++ wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2,
++ boost::placeholders::_3));
+ }
+
+ void WalletModel::unsubscribeFromCoreSignals()
+ {
+ // Disconnect signals from wallet
+- wallet->NotifyStatusChanged.disconnect(boost::bind(&NotifyKeyStoreStatusChanged, this, _1));
+- wallet->NotifyAddressBookChanged.disconnect(boost::bind(NotifyAddressBookChanged, this, _1, _2, _3, _4, _5));
+- wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
++ wallet->NotifyStatusChanged.disconnect(boost::bind(&NotifyKeyStoreStatusChanged, this, boost::placeholders::_1));
++ wallet->NotifyAddressBookChanged.disconnect(boost::bind(NotifyAddressBookChanged, this, boost::placeholders::_1, boost::placeholders::_2,
++ boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5));
++ wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2,
++ boost::placeholders::_3));
+ }
+
+ // WalletModel::UnlockContext implementation
diff --git a/PKGBUILD b/PKGBUILD
index 4443a9f41e98..f79c609729c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=curecoin-qt-git
pkgver=v2.0.0.2.r24.g3ef6a62
-pkgrel=1
+pkgrel=2
pkgdesc="GUI client (wallet) for CureCoin cryptocurrency"
arch=('x86_64' 'i686')
url="https://curecoin.net/"
@@ -13,17 +13,24 @@ conflicts=('curecoin-qt')
depends=('qt5-base' 'qt5-tools' 'miniupnpc' 'boost-libs' 'openssl')
makedepends=('boost' 'db' 'git')
source=("git+https://github.com/cygnusxi/CurecoinSource.git"
+ "62.patch"
"curecoin.desktop")
sha256sums=('SKIP'
+ 'e4b91a65d1f1afe7c165cbc4f090bfe4dc914a36915e9ef5f5d6ba0a981db0af'
'47e4c7305240dd16361d922bf6bc3a86ee53d7e0bc43bdf12c341ea0b7968387')
pkgver() {
- cd ${srcdir}/CurecoinSource
+ cd "${srcdir}/CurecoinSource"
set -o pipefail
git describe --tags --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/CurecoinSource"
+ patch --forward --strip=1 --input="${srcdir}/62.patch"
+}
+
build() {
cd "${srcdir}/CurecoinSource"
qmake