summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHendrik 'T4cC0re' Meyer2020-11-16 11:12:37 +0100
committerHendrik 'T4cC0re' Meyer2020-11-16 11:12:37 +0100
commitda14fd25693dd70c69736ce3ebcf431f65e70c03 (patch)
treeadae970869e4933cd2217a3c808ec5080de9d865
parentfc61ad5183ba5616a879c4632d1f28e058088ad2 (diff)
downloadaur-da14fd25693dd70c69736ce3ebcf431f65e70c03.tar.gz
update curl to 7.73, quiche to master at release and fix builds for recent quiche versions
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e718a19d521..fb340761acce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = curl-http3
pkgdesc = An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3
- pkgver = 7.71.1
+ pkgver = 7.73.0
pkgrel = 1
url = https://curl.haxx.se
arch = x86_64
@@ -16,10 +16,10 @@ pkgbase = curl-http3
depends = libnghttp2
depends = libidn2
depends = libidn2.so
- source = https://curl.haxx.se/download/curl-7.71.1.tar.gz
- source = https://curl.haxx.se/download/curl-7.71.1.tar.gz.asc
+ source = https://curl.haxx.se/download/curl-7.73.0.tar.gz
+ source = https://curl.haxx.se/download/curl-7.73.0.tar.gz.asc
validpgpkeys = 27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2
- sha512sums = 614f8d67e6ee942cb5e57f2da1a3faaf84ebff549ffe383aaf3751a4de3c8874ff482076afa27a52e910a137dec9b0f6e98265dc7d4ad7c95845b63f39236fd4
+ sha512sums = 86996f7ce537cfc39be18a6a93af0524c7a878d9e003ce0106eb4ff6ce2dea99da1cb9af297b87f93b204b42a3d793198a6e01764aa2a06f5b6fe0623b008f88
sha512sums = SKIP
pkgname = curl-http3
diff --git a/PKGBUILD b/PKGBUILD
index 5fb4562ad12d..1a5b7d829f3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hendrik 'T4cC0re' Meyer <aur@t4cc0.re>
pkgname=curl-http3
-pkgver=7.71.1
+pkgver=7.73.0
pkgrel=1
pkgdesc="An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3"
arch=('x86_64')
@@ -13,8 +13,8 @@ source=("https://curl.haxx.se/download/curl-$pkgver.tar.gz"{,.asc})
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
#source=("curl-$pkgver.zip::https://github.com/curl/curl/archive/master.zip")
-# Master as of 2020-06-24
-_quiche_ref=de78c58d44556967f90fb6480312aa3f4d4e396d
+# Master as of 2020-10-14 (7.73.0 release day)
+_quiche_ref=107a054b73bb4d381931dbc46aecccbb1801d91a
build(){
rm -rf quiche
@@ -28,8 +28,8 @@ build(){
git submodule update --init --recursive
cargo build --release --features pkg-config-meta,qlog
- mkdir deps/boringssl/lib
- ln -vnf $(find target/release -name libcrypto.a -o -name libssl.a) deps/boringssl/lib/
+ mkdir deps/boringssl/src/lib
+ ln -vnf $(find target/release -name libcrypto.a -o -name libssl.a) deps/boringssl/src/lib/
cd ..
## Build curl
@@ -39,7 +39,7 @@ build(){
## Arch Linux build flags + BoringSSL and quiche
./configure \
LDFLAGS="-Wl,-rpath,${PWD}/../quiche/target/release" \
- --with-ssl=$PWD/../quiche/deps/boringssl \
+ --with-ssl=$PWD/../quiche/deps/boringssl/src \
--with-quiche=$PWD/../quiche/target/release \
--enable-alt-svc \
--prefix=/usr \
@@ -76,4 +76,4 @@ package() {
# libquice is requried
install -Dm755 quiche/target/release/libquiche.so "${pkgdir}/usr/lib/libquiche.so"
}
-sha512sums=(614f8d67e6ee942cb5e57f2da1a3faaf84ebff549ffe383aaf3751a4de3c8874ff482076afa27a52e910a137dec9b0f6e98265dc7d4ad7c95845b63f39236fd4 SKIP)
+sha512sums=(86996f7ce537cfc39be18a6a93af0524c7a878d9e003ce0106eb4ff6ce2dea99da1cb9af297b87f93b204b42a3d793198a6e01764aa2a06f5b6fe0623b008f88 SKIP)