summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHendrik 'T4cC0re' Meyer2020-06-24 14:49:31 +0200
committerHendrik 'T4cC0re' Meyer2020-06-24 14:49:31 +0200
commitf965326265383f8bdee45382075b3be720298e57 (patch)
tree9f1052b62faacd7f20ef79ed01583c85b91706bf
parent77c2ef64d0b1da324ce2fdaae57cbfd653bc0fc1 (diff)
downloadaur-f965326265383f8bdee45382075b3be720298e57.tar.gz
bump to curl 7.71.0 alongside some build changes
As it turns out, it is assumed, that the user takes the current master of quiche of the release date of curl. This has now been implemented by pinning the commit ref of the quiche master on the release date. This is intended to get updated on every update to this package. In addition, this package is now built in a reproducible way :)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD44
2 files changed, 24 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b589e6ba6653..efa9c0c6b4ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = curl-http3
pkgdesc = An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3
- pkgver = 7.70.0
- pkgrel = 3
+ pkgver = 7.71.0
+ pkgrel = 1
url = https://curl.haxx.se
arch = x86_64
license = MIT
@@ -16,10 +16,10 @@ pkgbase = curl-http3
depends = libnghttp2
depends = libidn2
depends = libidn2.so
- source = https://curl.haxx.se/download/curl-7.70.0.tar.gz
- source = https://curl.haxx.se/download/curl-7.70.0.tar.gz.asc
+ source = https://curl.haxx.se/download/curl-7.71.0.tar.gz
+ source = https://curl.haxx.se/download/curl-7.71.0.tar.gz.asc
validpgpkeys = 27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2
- sha512sums = 76f073f8e2b18326d8741774927e99bad038b02fdb4446f2fa8c1bc1cd8909ec7e666d4bac67e7ee87a80ba7010fcf21750fa44bc13edcfbab8a287cb2e3660e
+ sha512sums = c983a2a71bf5037a0f2b7f55b7638fbc1f43b4bd56db5c407ae42482b0dc9b94ae90a108c48e0526a5fa580d992d9c1a96b35d35f82ba0d4c982f9bf5ab695f6
sha512sums = SKIP
pkgname = curl-http3
diff --git a/PKGBUILD b/PKGBUILD
index d4cb08e15c6a..54dc79b5a440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hendrik 'T4cC0re' Meyer <aur@t4cc0.re>
pkgname=curl-http3
-pkgver=7.70.0
-pkgrel=3
+pkgver=7.71.0
+pkgrel=1
pkgdesc="An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3"
arch=('x86_64')
url="https://curl.haxx.se"
@@ -13,41 +13,35 @@ source=("https://curl.haxx.se/download/curl-$pkgver.tar.gz"{,.asc})
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
#source=("curl-$pkgver.zip::https://github.com/curl/curl/archive/master.zip")
-_quiche_tag=0.3.0
+# Master as of 2020-06-24
+_quiche_ref=de78c58d44556967f90fb6480312aa3f4d4e396d
build(){
- if test -e quiche; then
- rm -rf quiche
- fi
- git clone --recursive --branch ${_quiche_tag} --depth 1 https://github.com/cloudflare/quiche.git
-
- ## Build BoringSSL
- mkdir -p quiche/deps/boringssl/build
- cd quiche/deps/boringssl/build
-
- cmake -DCMAKE_POSITION_INDEPENDENT_CODE=on ..
- make
-
- cd ..
- mkdir -p .openssl/lib
- cp build/crypto/libcrypto.a build/ssl/libssl.a .openssl/lib
- ln -sf ${PWD}/include .openssl
- cd ../..
-
+ rm -rf quiche
## Build quiche
- QUICHE_BSSL_PATH=$PWD/deps/boringssl cargo build --release --features pkg-config-meta
+ mkdir quiche
+ cd quiche
+ git init
+ git remote add origin https://github.com/cloudflare/quiche.git
+ git fetch --depth 1 origin ${_quiche_ref}
+ git checkout FETCH_HEAD
+ git submodule update --init --recursive
+
+ cargo build --release --features pkg-config-meta,qlog
+ mkdir deps/boringssl/lib
+ ln -vnf $(find target/release -name libcrypto.a -o -name libssl.a) deps/boringssl/lib/
cd ..
## Build curl
cd "curl-${pkgver}"
-# cd "curl-master"
./buildconf
## Arch Linux build flags + BoringSSL and quiche
./configure \
LDFLAGS="-Wl,-rpath,${PWD}/../quiche/target/release" \
- --with-ssl=$PWD/../quiche/deps/boringssl/.openssl \
+ --with-ssl=$PWD/../quiche/deps/boringssl \
--with-quiche=$PWD/../quiche/target/release \
+ --enable-alt-svc \
--prefix=/usr \
--mandir=/usr/share/man \
--disable-ldap \
@@ -82,4 +76,4 @@ package() {
# libquice is requried
install -Dm755 quiche/target/release/libquiche.so "${pkgdir}/usr/lib/libquiche.so"
}
-sha512sums=(76f073f8e2b18326d8741774927e99bad038b02fdb4446f2fa8c1bc1cd8909ec7e666d4bac67e7ee87a80ba7010fcf21750fa44bc13edcfbab8a287cb2e3660e SKIP)
+sha512sums=(c983a2a71bf5037a0f2b7f55b7638fbc1f43b4bd56db5c407ae42482b0dc9b94ae90a108c48e0526a5fa580d992d9c1a96b35d35f82ba0d4c982f9bf5ab695f6 SKIP)