summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZiah Jyothi2023-08-02 10:28:39 -0400
committerZiah Jyothi2023-08-02 10:29:34 -0400
commitde8be22324f3313cc75f3ded0d839fe145cacace (patch)
tree14bc4abe2000df40f00ec4d175fe0ff5ff871b9a
parentfe4d2ebf69b2b46c8335978fedbf3f54c2fec4ed (diff)
downloadaur-de8be22324f3313cc75f3ded0d839fe145cacace.tar.gz
Update curl
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
-rw-r--r--ngtcp2-refactor-r3845.patch90
-rw-r--r--ngtcp2-refactor-r3898.patch37
4 files changed, 11 insertions, 155 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 591d4efcae03..083724068983 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = curl-http3-ngtcp2
pkgdesc = command line tool and library for transferring data with URLs - compiled with HTTP/3 support (using ngtcp2 and nghttp3)
- pkgver = 8.1.1
+ pkgver = 8.2.1
pkgrel = 1
url = https://curl.se/
arch = x86_64
@@ -27,14 +27,13 @@ pkgbase = curl-http3-ngtcp2
depends = libnghttp3.so
depends = ngtcp2
depends = libngtcp2.so
- provides = curl=8.1.1
+ depends = quictls-openssl
+ provides = curl=8.2.1
provides = libcurl.so
conflicts = curl
- source = git+https://github.com/curl/curl.git?signed#tag=4ac817f9884c538e1343219facae19d93a42778c
- source = ngtcp2-refactor-r3898.patch
+ source = git+https://github.com/curl/curl.git?signed#tag=51ca9c12f959b7e97c1e67d0bebb33aa0d1f28b2
validpgpkeys = 27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2
sha512sums = SKIP
- sha512sums = 45cc856dbba9c74e778d39c77293b12d5cecedbcb75b4a2c4634681078fcc4dd541be1331be1bb6af4ce926c78bbe48b62524fedf0adec9c28cf01fafccae5f2
pkgname = curl-http3-ngtcp2
@@ -42,7 +41,7 @@ pkgname = libcurl-http3-ngtcp2-compat
pkgdesc = command line tool and library for transferring data with URLs (no versioned symbols)
depends = curl-http3-ngtcp2
depends = openssl
- provides = libcurl-compat=8.1.1
+ provides = libcurl-compat=8.2.1
provides = libcurl-compat.so
conflicts = libcurl-compat
@@ -50,6 +49,6 @@ pkgname = libcurl-http3-ngtcp2-gnutls
pkgdesc = command line tool and library for transferring data with URLs (no versioned symbols, linked against gnutls)
depends = curl-http3-ngtcp2
depends = gnutls
- provides = libcurl-gnutls=8.1.1
+ provides = libcurl-gnutls=8.2.1
provides = libcurl-gnutls.so
conflicts = libcurl-gnutls
diff --git a/PKGBUILD b/PKGBUILD
index 307c7acfabf2..41292840f7a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgbase=curl-http3-ngtcp2
pkgname=(curl-http3-ngtcp2 libcurl-http3-ngtcp2-compat libcurl-http3-ngtcp2-gnutls)
-_tag='4ac817f9884c538e1343219facae19d93a42778c' # git rev-parse v${_tag_name}
-pkgver=8.1.1
+_tag='51ca9c12f959b7e97c1e67d0bebb33aa0d1f28b2' # git rev-parse v${_tag_name}
+pkgver=8.2.1
pkgrel=1
pkgdesc="command line tool and library for transferring data with URLs - compiled with HTTP/3 support (using ngtcp2 and nghttp3)"
arch=('x86_64')
@@ -16,19 +16,13 @@ url='https://curl.se/'
license=('MIT')
depends=('ca-certificates' 'brotli' 'libbrotlidec.so' 'krb5' 'libgssapi_krb5.so'
'libidn2' 'libidn2.so' 'libnghttp2' 'libpsl' 'libpsl.so' 'libssh2' 'libssh2.so'
- 'openssl' 'zlib' 'zstd' 'libzstd.so' 'nghttp3' 'libnghttp3.so' 'ngtcp2' 'libngtcp2.so')
+ 'openssl' 'zlib' 'zstd' 'libzstd.so' 'nghttp3' 'libnghttp3.so' 'ngtcp2' 'libngtcp2.so' 'quictls-openssl')
makedepends=('git' 'patchelf')
conflicts=('curl')
provides=("curl=${pkgver}" 'libcurl.so')
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
-source=("git+https://github.com/curl/curl.git?signed#tag=${_tag}"
-# "ngtcp2-refactor-r3845.patch"
- "ngtcp2-refactor-r3898.patch"
- )
-sha512sums=('SKIP'
-# 'fd0496462866aa67b86bd536a9d051dcab9f546a4bda80bd21a28a93aaac57d0d15ed8d19a36ade9642e10ae41922cb0bb63d56a96b4d79e69dda202fd686da5'
- '45cc856dbba9c74e778d39c77293b12d5cecedbcb75b4a2c4634681078fcc4dd541be1331be1bb6af4ce926c78bbe48b62524fedf0adec9c28cf01fafccae5f2'
- )
+source=("git+https://github.com/curl/curl.git?signed#tag=${_tag}")
+sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/curl"
@@ -38,16 +32,6 @@ pkgver() {
prepare() {
cd "${srcdir}/curl"
- local ngtcp2_version="$(pacman -Qi ngtcp2-git | grep -E '^Version\s*:\s*' | awk '{print $3}')"
-# if [ "$(sed -E 's/^r([0-9]+).*$/\1/g' <<< "$ngtcp2_version")" -ge 3845 ]; then
-# # Patch curl
-# patch -Np1 -i ../ngtcp2-refactor-r3845.patch
-# fi
- if [ "$(sed -E 's/^r([0-9]+).*$/\1/g' <<< "$ngtcp2_version")" -ge 3898 ]; then
- # Patch curl
- patch -Np1 -i ../ngtcp2-refactor-r3898.patch
- fi
-
# no '-DEV' in version, release date from tagged commit...
sed -i \
-e "/\WLIBCURL_VERSION\W/c #define LIBCURL_VERSION \"${pkgver}\"" \
diff --git a/ngtcp2-refactor-r3845.patch b/ngtcp2-refactor-r3845.patch
deleted file mode 100644
index 184d5ac5d9f3..000000000000
--- a/ngtcp2-refactor-r3845.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff --unified --recursive --text curl.orig/lib/vquic/curl_ngtcp2.c curl.new/lib/vquic/curl_ngtcp2.c
---- curl.orig/lib/vquic/curl_ngtcp2.c 2023-04-26 23:00:39.460374064 -0400
-+++ curl.new/lib/vquic/curl_ngtcp2.c 2023-04-26 23:05:28.030119170 -0400
-@@ -133,7 +133,7 @@
- uint32_t version;
- ngtcp2_settings settings;
- ngtcp2_transport_params transport_params;
-- ngtcp2_connection_close_error last_error;
-+ ngtcp2_ccerr last_error;
- ngtcp2_crypto_conn_ref conn_ref;
- #ifdef USE_OPENSSL
- SSL_CTX *sslctx;
-@@ -653,7 +653,7 @@
- DEBUGF(LOG_CF(data, cf, "[h3sid=%" PRId64 "] read_stream(len=%zu) -> %zd",
- stream_id, buflen, nconsumed));
- if(nconsumed < 0) {
-- ngtcp2_connection_close_error_set_application_error(
-+ ngtcp2_ccerr_set_application_error(
- &ctx->last_error,
- nghttp3_err_infer_quic_app_error_code((int)nconsumed), NULL, 0);
- return NGTCP2_ERR_CALLBACK_FAILURE;
-@@ -712,7 +712,7 @@
- DEBUGF(LOG_CF(data, cf, "[h3sid=%" PRId64 "] quic close(err=%"
- PRIu64 ") -> %d", stream3_id, app_error_code, rv));
- if(rv) {
-- ngtcp2_connection_close_error_set_application_error(
-+ ngtcp2_ccerr_set_application_error(
- &ctx->last_error, nghttp3_err_infer_quic_app_error_code(rv), NULL, 0);
- return NGTCP2_ERR_CALLBACK_FAILURE;
- }
-@@ -1202,7 +1202,7 @@
- int rc;
- int64_t ctrl_stream_id, qpack_enc_stream_id, qpack_dec_stream_id;
-
-- if(ngtcp2_conn_get_max_local_streams_uni(ctx->qconn) < 3) {
-+ if(ngtcp2_conn_get_streams_uni_left(ctx->qconn) < 3) {
- return CURLE_QUIC_CONNECT_ERROR;
- }
-
-@@ -1817,12 +1817,12 @@
- ngtcp2_strerror(rv)));
- if(!ctx->last_error.error_code) {
- if(rv == NGTCP2_ERR_CRYPTO) {
-- ngtcp2_connection_close_error_set_transport_error_tls_alert(
-+ ngtcp2_ccerr_set_tls_alert(
- &ctx->last_error,
- ngtcp2_conn_get_tls_alert(ctx->qconn), NULL, 0);
- }
- else {
-- ngtcp2_connection_close_error_set_transport_error_liberr(
-+ ngtcp2_ccerr_set_liberr(
- &ctx->last_error, rv, NULL, 0);
- }
- }
-@@ -1875,7 +1875,7 @@
- if(rv) {
- failf(data, "ngtcp2_conn_handle_expiry returned error: %s",
- ngtcp2_strerror(rv));
-- ngtcp2_connection_close_error_set_transport_error_liberr(&ctx->last_error,
-+ ngtcp2_ccerr_set_liberr(&ctx->last_error,
- rv, NULL, 0);
- return CURLE_SEND_ERROR;
- }
-@@ -1904,7 +1904,7 @@
- if(veccnt < 0) {
- failf(data, "nghttp3_conn_writev_stream returned error: %s",
- nghttp3_strerror((int)veccnt));
-- ngtcp2_connection_close_error_set_application_error(
-+ ngtcp2_ccerr_set_application_error(
- &ctx->last_error,
- nghttp3_err_infer_quic_app_error_code((int)veccnt), NULL, 0);
- return CURLE_SEND_ERROR;
-@@ -1962,7 +1962,7 @@
- assert(ndatalen == -1);
- failf(data, "ngtcp2_conn_writev_stream returned error: %s",
- ngtcp2_strerror((int)outlen));
-- ngtcp2_connection_close_error_set_transport_error_liberr(
-+ ngtcp2_ccerr_set_liberr(
- &ctx->last_error, (int)outlen, NULL, 0);
- return CURLE_SEND_ERROR;
- }
-@@ -2277,7 +2277,7 @@
- ngtcp2_conn_set_tls_native_handle(ctx->qconn, ctx->ssl);
- #endif
-
-- ngtcp2_connection_close_error_default(&ctx->last_error);
-+ ngtcp2_ccerr_default(&ctx->last_error);
-
- ctx->conn_ref.get_conn = get_conn;
- ctx->conn_ref.user_data = cf;
diff --git a/ngtcp2-refactor-r3898.patch b/ngtcp2-refactor-r3898.patch
deleted file mode 100644
index c8e383edc0a2..000000000000
--- a/ngtcp2-refactor-r3898.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff '--color=auto' --unified --recursive --text curl.orig/lib/vquic/curl_ngtcp2.c curl.new/lib/vquic/curl_ngtcp2.c
---- curl.orig/lib/vquic/curl_ngtcp2.c 2023-05-23 20:05:53.020415661 -0400
-+++ curl.new/lib/vquic/curl_ngtcp2.c 2023-05-23 20:05:58.900589332 -0400
-@@ -326,7 +326,7 @@
- t->initial_max_streams_uni = QUIC_MAX_STREAMS;
- t->max_idle_timeout = QUIC_IDLE_TIMEOUT;
- if(ctx->qlogfd != -1) {
-- s->qlog.write = qlog_callback;
-+ s->qlog_write = qlog_callback;
- }
- }
-
-@@ -901,13 +901,13 @@
- return 0;
- }
-
--static int cb_recv_rx_key(ngtcp2_conn *tconn, ngtcp2_crypto_level level,
-+static int cb_recv_rx_key(ngtcp2_conn *tconn, ngtcp2_encryption_level level,
- void *user_data)
- {
- struct Curl_cfilter *cf = user_data;
- (void)tconn;
-
-- if(level != NGTCP2_CRYPTO_LEVEL_APPLICATION) {
-+ if(level != NGTCP2_ENCRYPTION_LEVEL_1RTT) {
- return 0;
- }
-
-@@ -2391,7 +2391,7 @@
-
- out:
- if(result == CURLE_RECV_ERROR && ctx->qconn &&
-- ngtcp2_conn_is_in_draining_period(ctx->qconn)) {
-+ ngtcp2_conn_in_draining_period(ctx->qconn)) {
- /* When a QUIC server instance is shutting down, it may send us a
- * CONNECTION_CLOSE right away. Our connection then enters the DRAINING
- * state.