summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Lansdowne2019-04-08 21:39:01 +0100
committerJoseph Lansdowne2019-04-08 21:39:01 +0100
commit6aea86815039a5f7d6454097e9954d2a53952da3 (patch)
treecf3d36cc7768bcf7e68c7df4ae27bf83457fbdf3
downloadaur-6aea86815039a5f7d6454097e9954d2a53952da3.tar.gz
curlftpfs-ng 0.9.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..829f465ae034
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Apr 8 20:36:26 UTC 2019
+pkgbase = curlftpfs-ng
+ pkgdesc = FUSE filesystem for FTP
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://ikn.org.uk/CurlFtpFS-NG
+ arch = x86_64
+ license = GPL
+ depends = curl
+ depends = fuse2
+ depends = glib2
+ conflicts = curlftpfs
+ source = http://ikn.org.uk/files/desktop/curlftpfs-ng/curlftpfs-ng-0.9.3.tar.gz
+ sha512sums = 17ea2480f9f3e9756d0884db5b0326e66332970674965153f221904f4de93c0154b356c2848fd962f4b5b8e2d10554f5a5b854989b984786825279b6e5dbca28
+
+pkgname = curlftpfs-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03a4005afe18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Joseph Lansdowne <ikn@ikn.org.uk>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Allan McRae <mcrae_allan@hotmail.com>
+# Contributor: Philip Nilsson <leffeman@gmail.com>
+
+pkgname=curlftpfs-ng
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="FUSE filesystem for FTP"
+url="http://ikn.org.uk/CurlFtpFS-NG"
+license=('GPL')
+depends=('curl' 'fuse2' 'glib2')
+arch=('x86_64')
+source=(http://ikn.org.uk/files/desktop/$pkgname/$pkgname-$pkgver.tar.gz)
+sha512sums=('17ea2480f9f3e9756d0884db5b0326e66332970674965153f221904f4de93c0154b356c2848fd962f4b5b8e2d10554f5a5b854989b984786825279b6e5dbca28')
+conflicts=(curlftpfs)
+
+build () {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}