summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianfeng Zhang2019-08-15 12:05:28 -0700
committerJianfeng Zhang2019-08-15 12:05:28 -0700
commit8ee2ab0e4cfdee34f4e2a9468d46c246d13a0485 (patch)
tree25b3ee2e76f8bd795a98e57d28e939b62cdc3605
downloadaur-8ee2ab0e4cfdee34f4e2a9468d46c246d13a0485.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4d48a7353ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = curlie
+ pkgdesc = A frontend to curl that adds the ease of use of httpie
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://curlie.io/
+ arch = x86_64
+ license = MIT
+ makedepends = go-pie
+ source = git+https://github.com/rs/curlie.git#tag=v1.2.0
+ sha256sums = SKIP
+
+pkgname = curlie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7faf0f3f7240
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jianfeng Zhang <swordfeng123@gmail.com>
+
+pkgname=curlie
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A frontend to curl that adds the ease of use of httpie'
+arch=('x86_64')
+url="https://curlie.io/"
+license=('MIT')
+makedepends=('go-pie')
+source=("git+https://github.com/rs/curlie.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}