summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlearchos-Angelos Gkountras2017-11-16 02:15:41 +0200
committerKlearchos-Angelos Gkountras2017-11-16 02:15:41 +0200
commit4bb44886609e0c46812be8e5de05e46a138ae1ed (patch)
tree8bd5955f8ca24c50038774a3be6b8823e51d3f5d
downloadaur-4bb44886609e0c46812be8e5de05e46a138ae1ed.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d6c1de49a18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = curseradio-git
+ pkgdesc = Command line radio player
+ pkgver = r15.1bd4bd0
+ pkgrel = 1
+ url = https://github.com/chronitis/curseradio
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-requests
+ depends = python-xdg
+ depends = python-lxml
+ provides = curseradio-git
+ options = !emptydirs
+ source = git+https://github.com/chronitis/curseradio.git
+ md5sums = SKIP
+
+pkgname = curseradio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51d0fc4309e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer: Klearchos-Angelos Gkountras <jemadux at cryptolab dot net>
+pkgname=curseradio-git
+_pkgname=curseradio
+pkgver=r15.1bd4bd0
+pkgrel=1
+pkgdesc="Command line radio player"
+arch=('any')
+url="https://github.com/chronitis/curseradio"
+license=('MIT')
+depends=('python' 'python-requests' 'python-xdg' 'python-lxml')
+makedepends=('git')
+provides=('curseradio-git')
+options=(!emptydirs)
+source=("git+https://github.com/chronitis/curseradio.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: