summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2019-03-10 21:36:52 -0700
committerMike Swanson2019-03-10 21:36:52 -0700
commit3fd504d64ef7665e993c2ba9e047b657df747d66 (patch)
tree9c284c072244aa92ceb90768b663614c921029de
downloadaur-3fd504d64ef7665e993c2ba9e047b657df747d66.tar.gz
cursewords 1.0.3
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52c43b7545a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cursewords
+ pkgdesc = Terminal-based crossword puzzle solver
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/thisisparker/cursewords
+ arch = any
+ license = AGPL3
+ depends = python
+ depends = python-blessed
+ depends = python-puzpy
+ source = https://github.com/thisisparker/cursewords/archive/v1.0.3.tar.gz
+ sha512sums = d599fca05fc4ca61ef06f5c5ab743cb72eebfc1831bc88f108289cba513eba69b6e9b889b9d520ee195714d06c033b9e39c15a5d40ab7bf19a6cba3ee5b0bfc3
+
+pkgname = cursewords
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..665307854be8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96fecf57abb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+pkgname=cursewords
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Terminal-based crossword puzzle solver"
+arch=('any')
+url="https://github.com/thisisparker/cursewords"
+license=('AGPL3')
+depends=('python' 'python-blessed' 'python-puzpy')
+source=("$url/archive/v$pkgver.tar.gz")
+sha512sums=('d599fca05fc4ca61ef06f5c5ab743cb72eebfc1831bc88f108289cba513eba69b6e9b889b9d520ee195714d06c033b9e39c15a5d40ab7bf19a6cba3ee5b0bfc3')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py install --prefix=/usr --root="$pkgdir"
+}