summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors-ol2018-10-03 14:22:58 +1000
committers-ol2018-10-03 14:40:31 +1000
commit840ad58aed8297a95ca42db70fef1daea9dfbcc8 (patch)
tree03a7a07fd9b79dff63db958207e96cb22f384043
downloadaur-840ad58aed8297a95ca42db70fef1daea9dfbcc8.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--remove_lang_file.patch15
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d943f1d06a2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = curv-git
+ pkgdesc = a language for making art using mathematics
+ pkgver = 0.3.r43.g7d922f3
+ pkgrel = 1
+ url = https://github.com/doug-moen/curv
+ arch = x86_64
+ license = Apache
+ makedepends = make
+ makedepends = cmake
+ makedepends = git
+ makedepends = boost
+ makedepends = glm
+ depends = boost-libs
+ depends = double-conversion
+ depends = openexr
+ depends = intel-tbb
+ source = git+https://github.com/doug-moen/curv
+ source = remove_lang_file.patch
+ md5sums = SKIP
+ md5sums = 6fd7fe6e81988bd9cd23d85ac920dc3c
+
+pkgname = curv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46a8084f190c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Sol Bekic <s+aur at s-ol dot nu>
+
+_pkgname=curv
+pkgname="$_pkgname-git"
+pkgver=0.3.r43.g7d922f3
+pkgrel=1
+pkgdesc="a language for making art using mathematics"
+url="https://github.com/doug-moen/curv"
+arch=('x86_64')
+license=('Apache')
+makedepends=('make' 'cmake' 'git' 'boost' 'glm')
+depends=('boost-libs' 'double-conversion' 'openexr' 'intel-tbb')
+
+source=("git+https://github.com/doug-moen/curv"
+ "remove_lang_file.patch")
+md5sums=('SKIP'
+ '6fd7fe6e81988bd9cd23d85ac920dc3c')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule update --init
+ patch -Np1 -i "${srcdir}/remove_lang_file.patch"
+
+ mkdir -p release
+ cd release
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}"/usr ..
+}
+
+build() {
+ cd "$_pkgname"/release
+ make
+}
+
+package() {
+ cd "$_pkgname"/release
+ make install
+}
diff --git a/remove_lang_file.patch b/remove_lang_file.patch
new file mode 100644
index 000000000000..92258fd2eed2
--- /dev/null
+++ b/remove_lang_file.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eadb514..b190a0b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -77,10 +77,3 @@ add_dependencies(tests tester curv)
+ install(TARGETS curv RUNTIME DESTINATION bin)
+ install(FILES lib/std.curv DESTINATION lib)
+ install(DIRECTORY lib/curv DESTINATION lib)
+-
+-file(GLOB GeditDir
+- "/usr/local/share/gtksourceview-[234].0/language-specs"
+- "/usr/share/gtksourceview-[234].0/language-specs")
+-foreach(Dir ${GeditDir})
+- install(FILES lib/curv.lang DESTINATION "${Dir}")
+-endforeach(Dir)