summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors-ol2018-10-06 17:09:19 +1000
committers-ol2018-10-06 17:09:19 +1000
commit9fe960bb5553102e7cf94f635a8a7a5d578b043a (patch)
tree607b7f3c075ffef1655ad6bdcf04f5376fc9a632
parent18088fccb09333207ef0da2b78f8ec958105f94d (diff)
downloadaur-9fe960bb5553102e7cf94f635a8a7a5d578b043a.tar.gz
simplify build process (see issue #41)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--remove_lang_file.patch15
3 files changed, 6 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a075b3bfea51..411c0057bfd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = curv-git
pkgdesc = a language for making art using mathematics
- pkgver = 0.3.r43.g7d922f3
- pkgrel = 3
+ pkgver = 0.3.r50.g1bb201b
+ pkgrel = 1
url = https://github.com/doug-moen/curv
arch = x86_64
license = Apache
@@ -15,9 +15,7 @@ pkgbase = curv-git
depends = ilmbase
depends = intel-tbb
source = git+https://github.com/doug-moen/curv
- source = remove_lang_file.patch
md5sums = SKIP
- md5sums = 6fd7fe6e81988bd9cd23d85ac920dc3c
pkgname = curv-git
diff --git a/PKGBUILD b/PKGBUILD
index cc5ea1aa6bdb..5429e6355335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=curv
pkgname="$_pkgname-git"
-pkgver=0.3.r43.g7d922f3
-pkgrel=3
+pkgver=0.3.r50.g1bb201b
+pkgrel=1
pkgdesc="a language for making art using mathematics"
url="https://github.com/doug-moen/curv"
arch=('x86_64')
@@ -11,10 +11,8 @@ license=('Apache')
makedepends=('cmake' 'git' 'boost' 'openexr' 'glm')
depends=('boost-libs' 'double-conversion' 'ilmbase' 'intel-tbb')
-source=("git+https://github.com/doug-moen/curv"
- "remove_lang_file.patch")
-md5sums=('SKIP'
- '6fd7fe6e81988bd9cd23d85ac920dc3c')
+source=("git+https://github.com/doug-moen/curv")
+md5sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -24,10 +22,6 @@ pkgver() {
prepare() {
cd "$_pkgname"
git submodule update --init
- patch -Np1 -i "${srcdir}/remove_lang_file.patch"
-
- echo '#define CURV_VERSION "'`git describe --tags --always --dirty`'"' >,v
- if cmp -s ,v libcurv/version.h; then rm ,v; else mv ,v libcurv/version.h; fi
mkdir -p release
cd release
diff --git a/remove_lang_file.patch b/remove_lang_file.patch
deleted file mode 100644
index 92258fd2eed2..000000000000
--- a/remove_lang_file.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index eadb514..b190a0b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -77,10 +77,3 @@ add_dependencies(tests tester curv)
- install(TARGETS curv RUNTIME DESTINATION bin)
- install(FILES lib/std.curv DESTINATION lib)
- install(DIRECTORY lib/curv DESTINATION lib)
--
--file(GLOB GeditDir
-- "/usr/local/share/gtksourceview-[234].0/language-specs"
-- "/usr/share/gtksourceview-[234].0/language-specs")
--foreach(Dir ${GeditDir})
-- install(FILES lib/curv.lang DESTINATION "${Dir}")
--endforeach(Dir)