summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Campello Ferreira2017-12-17 13:59:02 -0200
committerMarcel Campello Ferreira2017-12-17 13:59:02 -0200
commitccdcc108d39c81d98bb6af65b0633674b652561f (patch)
treebf3d2d1c077c28488e34c63b9575ee09d825e94c
parent372b0a78e6bb6aa18b6f5c94fcb77f184aa4030a (diff)
downloadaur-ccdcc108d39c81d98bb6af65b0633674b652561f.tar.gz
My first version.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--README.md1
3 files changed, 35 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1aeb32eb72a2..015eab9552bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = customizepkg
- pkgdesc = A new attempt at evolving customizepkg.
- pkgver = 0.0.1
+ pkgdesc = A tool to modify automatically PKGBUILD
+ pkgver = 57.f1d7be7
pkgrel = 1
url = https://github.com/tucho/customizepkg
arch = any
- license = none
+ license = GPL
depends = bash
+ depends = diffutils
+ optdepends = vim: for vimdiff
+ optdepends = colordiff: for colored diff output
provides = customizepkg
- conflicts = customizepkg-git
+ conflicts = customizepkg
+ conflicts = customizepkg-ald
conflicts = customizepkg-patching
- conflicts = custpmizepkg-scripting
- backup = etc/customizepkg.d/
- source = https://github.com/tucho/customizepkg/archive/0.0.1.tar.gz
- sha256sums = 313be366a0fa6c20de5618f3c3896608891ff2e382ffff06ea8ff7cf9a98bab6
+ conflicts = customizepkg-scripting
+ source = git+https://github.com/tucho/customizepkg.git
+ sha1sums = SKIP
pkgname = customizepkg
diff --git a/PKGBUILD b/PKGBUILD
index 325017302b1f..ba9612ad408f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: Marcel Campello Ferreira <tucho@prafrentex.com.br>
pkgname=customizepkg
-pkgver=0.0.1
+pkgver=57.f1d7be7
pkgrel=1
-pkgdesc="A new attempt at evolving customizepkg."
-arch=(any)
-url=https://github.com/tucho/customizepkg
-license=(none)
-depends=(bash)
-provides=(customizepkg)
-conflicts=(customizepkg-git customizepkg-patching custpmizepkg-scripting)
-backup=(etc/customizepkg.d/)
-source=($url/archive/$pkgver.tar.gz)
-sha256sums=(313be366a0fa6c20de5618f3c3896608891ff2e382ffff06ea8ff7cf9a98bab6)
+pkgdesc="A tool to modify automatically PKGBUILD"
+url="https://github.com/tucho/customizepkg"
+license=('GPL')
+arch=('any')
+depends=('bash' 'diffutils')
+provides=('customizepkg')
+conflicts=('customizepkg' 'customizepkg-ald' 'customizepkg-patching' 'customizepkg-scripting')
+optdepends=(
+ 'vim: for vimdiff'
+ 'colordiff: for colored diff output'
+)
+source=(git+https://github.com/tucho/customizepkg.git)
+sha1sums=('SKIP')
-package() {
- install -D -m 755 ${srcdir}/${pkgname}-${pkgver}/customizepkg ${pkgdir}/usr/bin/customizepkg
- mkdir -p ${pkgdir}/etc/customizepkg.d/
+pkgver() {
+ cd ${pkgname}
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd ${pkgname}
+ install -D -m 755 ${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+ mkdir -p "${pkgdir}"/etc/customizepkg.d/
+ cp -R examples/*.example "${pkgdir}"/etc/customizepkg.d/
}
diff --git a/README.md b/README.md
deleted file mode 100644
index 57ea2d267ccf..000000000000
--- a/README.md
+++ /dev/null
@@ -1 +0,0 @@
-# customizepkg_abs-pkg \ No newline at end of file