summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordbrgn2015-07-25 16:09:40 +0200
committerdbrgn2015-07-25 16:09:40 +0200
commitc6c167c1a89775c995fb19d2a487486da22599c5 (patch)
treedade23f3495e1ad958b8e597a968b3144a5eb2b1
downloadaur-c6c167c1a89775c995fb19d2a487486da22599c5.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD47
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf908ac0cd49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cute
+ pkgdesc = An easy to use C++ unit testing framework
+ pkgver = 2.0.0
+ pkgrel = 3
+ url = http://www.cute-test.com/
+ arch = any
+ license = LGPL
+ depends = boost-libs
+ source = http://www.cute-test.com/attachments/download/61/cute2_0_0.tar.gz
+ sha256sums = 87ff94560a2fe8b978d06f40023b22c0ae9b87cf02716b019afe9f84551e14aa
+
+pkgname = cute
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f12cf2d600d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=cute
+pkgver=2.0.0
+_pkgver=2_0_0
+_downloadid=61
+pkgrel=3
+pkgdesc="An easy to use C++ unit testing framework"
+arch=("any")
+url="http://www.cute-test.com/"
+license=("LGPL")
+depends=("boost-libs")
+source=("http://www.cute-test.com/attachments/download/${_downloadid}/${pkgname}${_pkgver}.tar.gz")
+sha256sums=('87ff94560a2fe8b978d06f40023b22c0ae9b87cf02716b019afe9f84551e14aa')
+
+check() {
+ cd ${srcdir}/cute_tests
+ echo -e "\e[1m \e[34m->\e[39m Building CUTE test suite...\e[0m"
+ g++ -Wall -I../cute_lib/ main.cpp \
+ test_cute.cpp \
+ test_cute_data_driven.cpp \
+ test_cute_equals.cpp \
+ test_cute_expect.cpp \
+ test_cute_filter_runner.cpp \
+ test_cute_relops.cpp \
+ test_cute_runner.cpp \
+ test_cute_suite.cpp \
+ test_cute_suite_test.cpp \
+ test_cute_test.cpp \
+ test_cute_test_incarnate.cpp \
+ test_cute_testmember.cpp \
+ test_cute_to_string.cpp \
+ test_cute_to_string_embedded.cpp \
+ test_repeated_test.cpp \
+ test_xml_file_opener.cpp \
+ test_xml_listener.cpp \
+ -o test
+ echo -e "\e[1m \e[34m->\e[39m Running CUTE test suite...\e[0m"
+ ./test > /dev/null
+ echo -e "\e[1m \e[34m->\e[39m OK!\e[0m"
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/include/cute
+ cd ${srcdir}/cute_lib/
+ cp *.h ${pkgdir}/usr/include/cute/
+}
+
+# vim:set ts=2 sw=2 et: