summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkureta2020-08-13 13:56:25 +0300
committerkureta2020-08-13 13:56:25 +0300
commit921c4ac7cd617190470c95ddd009cc5c2189e497 (patch)
tree87e0383139ae6edd2c8497be783f4a9b7f83797b
parent0d9c45501fa23b6a8172f7d8d3d034c8c37c7e4d (diff)
downloadaur-921c4ac7cd617190470c95ddd009cc5c2189e497.tar.gz
Updated to version 1.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16d8e3b89869..643fcbe53f14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cutechess
pkgdesc = Tools for working with chess engines
- pkgver = 1.0.0
+ pkgver = 1.2.0
pkgrel = 1
url = http://cutechess.com
arch = i686
@@ -8,8 +8,8 @@ pkgbase = cutechess
license = GPL3
makedepends = doxygen
depends = qt5-svg
- source = https://github.com/cutechess/cutechess/archive/gui-1.0.0.tar.gz
- sha256sums = b85967c225e70eed88c1b64d42542bdb21c8f3f52fd17765200073e390aaba04
+ source = https://github.com/cutechess/cutechess/archive/1.2.0.tar.gz
+ sha256sums = d0e1b2c9c2eaccf0f8c4d5e5fe7e169358f5de9606bd27de3f9d1ce4ddcdb0bc
pkgname = cutechess
pkgdesc = A graphical interface for chess
diff --git a/PKGBUILD b/PKGBUILD
index 566dd919d477..7948929fb009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=cutechess
pkgname=(cutechess cutechess-cli libcutechess libcutechess-docs)
-pkgver=1.0.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="Tools for working with chess engines"
arch=(i686 x86_64)
@@ -10,17 +10,17 @@ url=http://cutechess.com
license=(GPL3)
depends=(qt5-svg)
makedepends=(doxygen)
-source=(https://github.com/$pkgname/$pkgname/archive/gui-$pkgver.tar.gz)
-sha256sums=(b85967c225e70eed88c1b64d42542bdb21c8f3f52fd17765200073e390aaba04)
+source=(https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz)
+sha256sums=('d0e1b2c9c2eaccf0f8c4d5e5fe7e169358f5de9606bd27de3f9d1ce4ddcdb0bc')
prepare() {
- cd $pkgbase-gui-$pkgver/projects
+ cd $pkgbase-$pkgver/projects
sed -n '2,23s:^[ ]*::p' gui/components/pgnhighlighter/src/pgnhighlighter.h > COPYING.gui
sed -n '2,23s:^[ ]*::p' lib/components/json/src/jsonparser.h > COPYING.lib
}
build() {
- cd $pkgbase-gui-$pkgver
+ cd $pkgbase-$pkgver
qmake
make
}
@@ -29,7 +29,7 @@ package_cutechess() {
pkgdesc="A graphical interface for chess"
license=(GPL3 MIT)
- cd $pkgbase-gui-$pkgver/projects
+ cd $pkgbase-$pkgver/projects
install -Dm755 gui/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 COPYING.gui "$pkgdir"/usr/share/licenses/$pkgname/COPYING
install -Dm644 gui/res/icons/${pkgname}_32x32.xpm \
@@ -42,7 +42,7 @@ package_cutechess-cli() {
pkgdesc="A command-line tool to automate chess engine tournaments"
depends=(qt5-base)
- cd $pkgbase-gui-$pkgver
+ cd $pkgbase-$pkgver
install -Dm755 projects/cli/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 docs/$pkgname.6 "$pkgdir"/usr/share/man/man6/$pkgname.6
install -Dm644 docs/engines.json.5 "$pkgdir"/usr/share/man/man5/engines.json.5
@@ -54,7 +54,7 @@ package_libcutechess() {
depends=()
options=(staticlibs)
- cd $pkgbase-gui-$pkgver/projects
+ cd $pkgbase-$pkgver/projects
install -Dm644 lib/$pkgname.a "$pkgdir"/usr/lib/$pkgname.a
install -Dm644 COPYING.lib "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
@@ -65,7 +65,7 @@ package_libcutechess-docs() {
depends=()
options=(docs)
- cd $pkgbase-gui-$pkgver
+ cd $pkgbase-$pkgver
make doc-api
install -dm755 "$pkgdir"/usr/share/doc/${pkgname%-*}/html/
install -m644 docs/api/html/* "$pkgdir"/usr/share/doc/${pkgname%-*}/html/